将文件系统复制到PC机上,然后再拷贝到别的SD卡后,发现mysql无法启动了,首先检查了一下mysql的错误日志,发现最后出现以下错误:

/usr/local/mysql/libexec/mysqld: File './mysql-bin.index' not found (Errcode: 13)

提示./mysql-bin.index无法找到(由于mysql开启了bin日志功能),到数据库根目录查看该文件是存在的,可能是文件权限的问题,查看了数据库根目录的权限是700,所有者和用户组都是root,可能是上次转移数据库的时候不小心修改了文件夹的权限。
解决方法:
chgrp -R mysql /usr/local/mysql && chown -R mysql /usr/local/mysql
重新启动mysql  [OK]

相关文章:

  • 2022-12-23
  • 2021-11-04
猜你喜欢
  • 2022-12-23
  • 2022-01-29
  • 2021-07-08
  • 2021-08-24
  • 2022-12-23
  • 2021-07-28
  • 2021-10-19
相关资源
相似解决方案