【问题标题】:phpMyAdmin - mySQL - Error importing data into wordpress - what is collation?phpMyAdmin - mySQL - 将数据导入 wordpress 时出错 - 什么是排序规则?
【发布时间】:2016-06-28 23:13:45
【问题描述】:

我在导入数据时遇到问题 排序规则是什么意思?

我问的原因是我一直收到导入数据的错误。所以我正在查看我的 wp-config 文件,排序规则如下所示。

/** Database Charset to use in creating database tables. */
define('DB_CHARSET', 'utf8mb4');

/** The Database Collate type. Don't change this if in doubt. */
define('DB_COLLATE', '');

所以我转到 phpMyAdmin 并且服务器字符集是 UTF-8 Unicode (utf8) 我不知道这是否有任何意义,但在服务器连接排序规则框中它显示为 utf8mb4_unicode_ci。

这就是我认为问题所在,但我是 mySQL 的新手。我的主要 wordpress 数据库旁边有排序规则类型latin1_swedish_ci - 在排序规则下。

当我点击进入数据库时​​,它们都有不同的 utf8 字符集,一些 utf8mb4_unicode_ci 和一些 utf8_general_ci - 这是否意味着数据库设置不正确?

这可能是我的导入问题的原因吗?我该如何解决。

【问题讨论】:

    标签: php mysql wordpress phpmyadmin


    【解决方案1】:

    这里有一些来自维基:

    Collation is the assembly of written information into a standard order. 
    Many systems of collation are based on numerical order or alphabetical 
    order, or extensions and combinations thereof.
    

    我的意见,它是数据库的字符集... 如果您想将数据库导入另一个地方,则排序规则必须相同/两台服务器具有相同的排序规则,,,

    【讨论】:

      【解决方案2】:

      排序规则可以在导出之前更改,所以我不会给你这个错误。我有以前的 pb,这对我有用。1)我将排序规则更改为与服务器相同 2)我在导出到 utf8 时选择了选项.

      您不能在记事本中更改排序规则。您必须确保在 phpmyadmin 中执行此步骤

      【讨论】:

        猜你喜欢
        • 1970-01-01
        • 2010-11-27
        • 2017-05-15
        • 2017-01-05
        • 2011-08-17
        • 2010-12-28
        • 2013-10-30
        • 1970-01-01
        • 2011-07-28
        相关资源
        最近更新 更多