【发布时间】:2016-06-28 23:13:45
【问题描述】:
我在导入数据时遇到问题 排序规则是什么意思?
我问的原因是我一直收到导入数据的错误。所以我正在查看我的 wp-config 文件,排序规则如下所示。
/** Database Charset to use in creating database tables. */
define('DB_CHARSET', 'utf8mb4');
/** The Database Collate type. Don't change this if in doubt. */
define('DB_COLLATE', '');
所以我转到 phpMyAdmin 并且服务器字符集是 UTF-8 Unicode (utf8) 我不知道这是否有任何意义,但在服务器连接排序规则框中它显示为 utf8mb4_unicode_ci。
这就是我认为问题所在,但我是 mySQL 的新手。我的主要 wordpress 数据库旁边有排序规则类型latin1_swedish_ci - 在排序规则下。
当我点击进入数据库时,它们都有不同的 utf8 字符集,一些 utf8mb4_unicode_ci 和一些 utf8_general_ci - 这是否意味着数据库设置不正确?
这可能是我的导入问题的原因吗?我该如何解决。
【问题讨论】:
标签: php mysql wordpress phpmyadmin