【问题标题】:MySQL error 1064 when importing Wordpress DB in PHPMyAdmin在 PHPMyAdmin 中导入 Wordpress DB 时出现 MySQL 错误 1064
【发布时间】:2011-08-17 01:18:25
【问题描述】:

我不得不在很多帖子中更改我的目录路径。我决定导出数据库并进行查找/替换以进行更改。但是当我将数据库导入回来时,我得到了错误

1064 - 您的 SQL 语法有错误;

我认为这是因为 mt charset 不理解它们 & & amp;

我怎样才能导入这个

【问题讨论】:

  • 需要更多信息。有问题的线是什么样的?你用什么来导出和导入数据库?您确定您没有使用查找/替换操作破坏文件吗?
  • 全部在 PHPMyAdmin 中。我导出了数据库并在 Dreamweaver 中进行了查找/替换以进行更改并将其导入。我还导入了备份(我导出的,未更改),错误再次发生。

标签: mysql wordpress phpmyadmin


【解决方案1】:

您没有在问题中提供太多信息,但我建议采用以下方法:

  • 从上次备份恢复
  • 看看 MySQL 的 REPLACE() 函数。它应该能够在数据库中完成所有查找/替换工作

【讨论】:

  • mysqldump生成的吗?如果您在文本编辑器中打开文件,它应该会在前 10 或 20 行通知您。
  • 不这么认为。 -- phpMyAdmin SQL Dump -- 版本 2.11.10 -- phpmyadmin.net -- -- 主机:localhost -- 生成时间:2011 年 5 月 2 日上午 10:21 -- 服务器版本:5.0.89 -- PHP 版本: 5.2.12 SET SQL_MODE="NO_AUTO_VALUE_ON_ZERO"; -- -- 数据库:mydb
【解决方案2】:

如果您首先使用命令行程序将文件从 utf-8 更改为 iso-8859-1,这可能会有所帮助。

启动命令行会话并更改目录,以便您在此文件所在的目录中并输入命令

iconv -cs -f UTF-8 -t ISO-8859-1 utf8.txt > iso.txt

如果您无法访问 linux 命令行,请使用 google 查找 windows 方法以在 utf8 和 iso 字符集之间进行转换。

【讨论】:

  • 除了 phpmyadmin 之外,我无权访问我的数据库
猜你喜欢
  • 2016-05-18
  • 2014-10-10
  • 1970-01-01
  • 1970-01-01
  • 2015-10-09
  • 2012-10-25
  • 1970-01-01
  • 1970-01-01
  • 2016-02-17
相关资源
最近更新 更多