【发布时间】:2021-01-15 05:16:27
【问题描述】:
有没有人在升级到 php 7.2.34 时遇到过这个错误?
在用户目录下运行 php 脚本似乎是一个错误,但对于我来说,我还找不到解决方案。
我假设(对于 linux 不是很好)这是本地用户帐户指向服务器上的错误位置的问题。
它在这里“/usr/lib64/php/modules/oci8” 哪个不存在,但“/usr/lib64/php/modules”包含了我所能知道的所有 .so 文件。
这是对原始 php 7.0 的完全卸载并升级到 7.2
错误
php -v
PHP Warning: PHP Startup: Unable to load dynamic library 'oci8' (tried: /usr/lib64/php/modules/oci8 (/usr/lib64/php/modules/oci8: cannot open shared object file: No such file or directory), /usr/lib64/php/modules/oci8.so (libclntsh.so.19.1: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library 'pdo_oci' (tried: /usr/lib64/php/modules/pdo_oci (/usr/lib64/php/modules/pdo_oci: cannot open shared object file: No such file or directory), /usr/lib64/php/modules/pdo_oci.so (libclntsh.so.19.1: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library 'oci8.so' (tried: /usr/lib64/php/modules/oci8.so (libclntsh.so.19.1: cannot open shared object file: No such file or directory), /usr/lib64/php/modules/oci8.so.so (/usr/lib64/php/modules/oci8.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP 7.2.34 (cli) (built: Jan 4 2021 14:20:18) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
with Zend OPcache v7.2.34, Copyright (c) 1999-2018, by Zend Technologies
ls -l /usr/lib64/php/modules的内容
bcmath.so
bz2.so
calendar.so
ctype.so
curl.so
dom.so
exif.so
fileinfo.so
ftp.so
gd.so
gettext.so
iconv.so
intl.so
json.so
ldap.so
mbstring.so
mcrypt.so
mysqli.so
mysqlnd.so
oci8.so
opcache.so
pdo_mysql.so
pdo_oci.so
pdo.so
pdo_sqlite.so
phar.so
posix.so
shmop.so
simplexml.so
sockets.so
sqlite3.so
sysvmsg.so
sysvsem.so
sysvshm.so
tokenizer.so
wddx.so
xmlreader.so
xml.so
xmlwriter.so
xsl.so
任何帮助表示赞赏。
【问题讨论】: