【发布时间】:2016-04-14 16:22:50
【问题描述】:
我是 root,我无法启动 httpd。
我执行/etc/init.d/httpd status 并得到:
httpd 已停止
当我尝试/etc/init.d/httpd start 时,我得到:
正在启动 httpd:(98)地址已在使用中:make_sock:无法绑定到地址 0.0.0.0:80
没有可用的监听套接字,正在关闭
无法打开日志
[失败]
我认为它可能被挂起,所以我检查了sudo netstat -tulpn | grep :80。
我什么都没有。
我检查了/var/log/httpd/error.log,它与此无关
只是想试试,我试过/etc/init.d/httpd reload
我收到了[FAILED]。
我需要做什么?
【问题讨论】:
-
我觉得这个可以回答你的问题:stackoverflow.com/questions/20001423/…
-
参考:stackoverflow.com/questions/46643780/… - 在 conf.d 中定义的文件将在多个文件中多次将监听端口设为 80,这可能会导致此问题。 - 似乎80端口被其他进程使用,可以通过“netstat -anp|grep :80”检查