【发布时间】:2013-09-13 18:41:39
【问题描述】:
一切正常,没有对配置进行任何编辑,突然httpd在启动时停止运行,我也提供了另一个服务。
硬盘已满的信息,所以我不得不删除一些文件。chkconfig --list 的结果是
httpd 0:off 1:off 2:on 3:on 4:on 5:on 6:off
【问题讨论】:
一切正常,没有对配置进行任何编辑,突然httpd在启动时停止运行,我也提供了另一个服务。
硬盘已满的信息,所以我不得不删除一些文件。chkconfig --list 的结果是
httpd 0:off 1:off 2:on 3:on 4:on 5:on 6:off
【问题讨论】:
如果 httpd 无法启动,您应该能够在错误日志中找到错误消息(/var/log/httpd/error_log 或您将错误配置到的任何位置)。检查您手动尝试启动服务时记录的内容 ("service httpd start"),如果您不明白它试图告诉您的内容,请返回更多信息。
【讨论】:
/var/log/httpd/ssl_error_log 在我的情况下有错误消息。
如果硬盘已满,那将是 apache 服务无法启动的第一个原因。您是否尝试在释放足够的磁盘空间后重新启动httpd 服务,同时请检查/var/log/httpd/error.log 中的httpd 错误日志。我认为主要问题是由于磁盘空间已满。
尝试释放一些日志文件以释放/var/log 目录中的更多空间。
【讨论】:
就我而言,这是日志配置的问题:
AH00015: Unable to open logs
(1)Operation not permitted: AH00091: httpd: could not open error log file /usr/teste.localhost-error.log.
我更改了我的日志路径,将文件创建到我设置的路径中,并在重新启动后工作。
【讨论】: