【问题标题】:Switch from MAMP to MAMP Pro, can't start mysql从 MAMP 切换到 MAMP Pro,无法启动 mysql
【发布时间】:2016-08-04 20:52:22
【问题描述】:

我成功使用了 MAMP,然后一旦我需要拥有多个本地开发环境,我就购买并下载了 MAMP Pro。现在,mysql 不会在 MAMP Pro 中启动,但在 MAMP 中仍然可以正常工作。

这里是mysql错误日志:

160804 16:21:27 mysqld_safe Starting mysqld daemon with databases from /Library/Application Support/appsolute/MAMP PRO/db/mysql
160804 16:21:27 [Warning] Setting lower_case_table_names=2 because file system for /Library/Application Support/appsolute/MAMP PRO/db/mysql/ is case insensitive
160804 16:21:27 [Note] Plugin 'FEDERATED' is disabled.
/Applications/MAMP/Library/bin/mysqld: Table 'mysql.plugin' doesn't exist
160804 16:21:27 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
160804 16:21:27 InnoDB:     The InnoDB memory heap is disabled
160804 16:21:27 InnoDB: Mutexes and rw_locks use GCC atomic builtins
160804 16:21:27 InnoDB: Compressed tables use zlib 1.2.3
160804 16:21:27 InnoDB: Initializing buffer pool, size = 128.0M
160804 16:21:27 InnoDB: Completed initialization of buffer pool
InnoDB: Error: space header page consists of zero bytes in data file ./ibdata1
160804 16:21:27 InnoDB: Could not open or create data files.
160804 16:21:27 InnoDB: If you tried to add new data files, and it failed here,
160804 16:21:27 InnoDB: you should now edit innodb_data_file_path in my.cnf back
160804 16:21:27 InnoDB: to what it was, and remove the new ibdata files InnoDB created
160804 16:21:27 InnoDB: in this failed attempt. InnoDB only wrote those files full of
160804 16:21:27 InnoDB: zeros, but did not yet use them in any way. But be careful: do not
160804 16:21:27 InnoDB: remove old data files which contain your precious data!
160804 16:21:27 [ERROR] Plugin 'InnoDB' init function returned error.
160804 16:21:27 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
160804 16:21:27 [ERROR] Unknown/unsupported storage engine: InnoDB
160804 16:21:27 [ERROR] Aborting

160804 16:21:27 [Note] /Applications/MAMP/Library/bin/mysqld: Shutdown complete

160804 16:21:27 mysqld_safe mysqld from pid file /Applications/MAMP/tmp/mysql/mysql.pid ended

【问题讨论】:

    标签: php mysql innodb mamp mamp-pro


    【解决方案1】:

    我使用 MAMP Pro 中的卸载程序卸载了 MAMP 和 MAMP Pro。我通过将应用程序拖入垃圾箱并清空垃圾箱来删除所有文件。我重新安装了一个新的 MAMP Pro 并且 mysql 按预期工作。

    【讨论】:

      猜你喜欢
      • 2019-05-16
      • 1970-01-01
      • 2015-11-08
      • 1970-01-01
      • 2018-05-08
      • 1970-01-01
      • 2017-02-18
      • 1970-01-01
      • 2017-01-12
      相关资源
      最近更新 更多