【问题标题】:MAMP PRO will not start MySQLMAMP PRO 不会启动 MySQL
【发布时间】:2018-05-08 20:43:29
【问题描述】:

我有 MAMP 和 MAMP PRO。 MAMP 工作正常,这可以成功启动 Apache 和 MySQL 并正常执行。 MAMP PRO 将拒绝启动 MySQL。我尝试了以下设置:

innodb_recovery_force = 1

即使设置为 6 级,这也无效。我尝试删除 MySQL DB 文件夹中包含的两个日志文件。这也没有成功。

我不关心数据库,我想要一个全新的开始。但是 MAMP PRO 拒绝工作。

下面是错误日志输出:

2017-11-24 20:52:31 10804 [ERROR] InnoDB: Attempted to open a previously opened tablespace. Previous tablespace macs2014_internal/btcontentlocal uses space ID: 358 at filepath: .\macs2014_internal\btcontentlocal.ibd. Cannot open tablespace tripeasi_whitelabel_mobile/authtypeconcretecookiemap which uses space ID: 358 at filepath: .\tripeasi_whitelabel_mobile\authtypeconcretecookiemap.ibd
InnoDB: Error: could not open single-table tablespace file .\tripeasi_whitelabel_mobile\authtypeconcretecookiemap.ibd

我已尝试多次完全重新安装 MAMP,但它似乎仍在寻找这些不再存在的数据库。正如我之前所说,我不在乎保存数据。

【问题讨论】:

    标签: php mysql apache mamp


    【解决方案1】:

    在您尝试在 MAMP 上启动 MySQL 服务器的同时,您是否有其他 MySQL 进程或服务器正在运行? (这可以在终端中使用 te "top" 命令进行检查)

    当我第一次安装 MAMP Pro 时,MySQL 服务器 (MAMP) 无法启动,这是因为 MySQL 服务器已经在运行。 (配置为随操作系统自动启动)

    如果是这样,您可以在终端中使用以下命令杀死所有 MySQL 进程(不要忘记停止 MAMP 服务器):sudo killall -9 mysqld

    您可以尝试的另一件事是:

    • 退出 MAMP

    • 在查找器中转到Library/Application Support/appsolute/MAMP PRO/db/mysql56/

    • 删除日志文件

    • 重启 MAMP

    我希望您的问题在尝试了其中一种后得到解决。

    亲切的问候,

    达克塔

    【讨论】:

    • 抱歉,我应该提到我正在使用 Windows。我试过删除日志文件,但没有成功。
    【解决方案2】:

    因此,Windows 上的文件夹位于 MAMP PRO 的公共文档中。这就是为什么我的所有设置都不能正常工作以及这些幻像数据库出现的原因。

    我去了:

    C:\Users\Public\Documents\Appsolute\MAMPPRO\db
    

    并从那里删除数据库,重新启动我的服务器,瞧——它工作正常。这是放置 MAMP PRO 设置的一个非常令人困惑的地方,我真的不明白为什么它们在那里,而不是你期望它们在程序文件中的位置。

    【讨论】:

      猜你喜欢
      • 2019-05-16
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 2014-06-20
      • 1970-01-01
      • 2015-11-08
      • 1970-01-01
      • 1970-01-01
      相关资源
      最近更新 更多