【发布时间】:2018-05-08 20:43:29
【问题描述】:
我有 MAMP 和 MAMP PRO。 MAMP 工作正常,这可以成功启动 Apache 和 MySQL 并正常执行。 MAMP PRO 将拒绝启动 MySQL。我尝试了以下设置:
innodb_recovery_force = 1
即使设置为 6 级,这也无效。我尝试删除 MySQL DB 文件夹中包含的两个日志文件。这也没有成功。
我不关心数据库,我想要一个全新的开始。但是 MAMP PRO 拒绝工作。
下面是错误日志输出:
2017-11-24 20:52:31 10804 [ERROR] InnoDB: Attempted to open a previously opened tablespace. Previous tablespace macs2014_internal/btcontentlocal uses space ID: 358 at filepath: .\macs2014_internal\btcontentlocal.ibd. Cannot open tablespace tripeasi_whitelabel_mobile/authtypeconcretecookiemap which uses space ID: 358 at filepath: .\tripeasi_whitelabel_mobile\authtypeconcretecookiemap.ibd
InnoDB: Error: could not open single-table tablespace file .\tripeasi_whitelabel_mobile\authtypeconcretecookiemap.ibd
我已尝试多次完全重新安装 MAMP,但它似乎仍在寻找这些不再存在的数据库。正如我之前所说,我不在乎保存数据。
【问题讨论】: