【问题标题】:Unable to connect to k8s cluster using master/worker IP无法使用 master/worker IP 连接到 k8s 集群
【发布时间】:2021-08-24 07:46:43
【问题描述】:

我正在尝试安装一个具有一个主节点和两个工作节点的 Kubernetes 集群。

为此,我购买了 3 个在 Ubuntu 21.10 上运行的虚拟机。在主节点,我安装了kubeadm:1.21.4、kubectl:1.21.4、kubelet:1.21.4和docker-ce:20.4。

我跟着this guide安装了集群。唯一的区别是在我的 init 命令中我没有提到--control-plane-endpoint。我使用 calico CNI v3.19.1 和 docker 进行 CRI Runtime。

安装集群后,我部署了 minio pod 并将其公开为 NodePort。 pod 部署在工作节点 (10.72.12.52) 中,我的主节点 IP 为 10.72.12.51)。 在前两个小时,我可以通过所有三个 IP(10.72.12.51:30981、10.72.12.52:30981、10.72.13.53:30981)访问登录页面。但是,两个小时后,我无法通过10.72.12.51:30981 和10.72.13.53:30981 访问该服务。现在我只能从运行它的节点(10.72.12.52)访问该服务。

我已禁用防火墙并在/etc/NetworkManager/conf.d 中添加了calico.conf 文件,内容如下:

[keyfile]
unmanaged-devices=interface-name:cali*;interface-name:tunl*;interface-name:vxlan.calico

我在设置中遗漏了什么可能会导致此问题?

【问题讨论】:

  • 你好@AbhinavSharma。很难说这里可能是什么问题。您能否检查kube-apiserver 是否已启动并运行?
  • 是的,所有 kube-system pod 都已启动并运行,没有任何错误。
  • calicoctl get nodes 和 kubectl get nodes 还显示所有三个节点都处于已​​建立和就绪状态
  • 嗨@AbhinavSharma。感谢您的回复。您能否也分享一下您在失去对服务的访问权限时遇到的确切错误?
  • 我在切换到flannel cni时能够得到预期的结果。

标签: kubernetes flannel calico kubernetes-cluster


【解决方案1】:

这是为提高可见性而发布的社区 wiki 答案。随意扩展它。

正如@AbhinavSharma 所述,问题已通过从 Calico 切换到 Flannel CNI 得到解决。

关于法兰绒本身的更多信息可以找到here。

【讨论】:

    猜你喜欢
    • 2020-04-28
    • 1970-01-01
    • 2019-08-03
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2019-07-25
    • 2021-11-23
    • 2018-11-01
    相关资源
    最近更新 更多