【问题标题】:SPF softfail dragging me to an abyssSPF softfail 将我拖入深渊
【发布时间】:2013-10-07 10:54:37
【问题描述】:

从我的 PHP 发送的邮件没有传递给某些客户,我怀疑这可能是由于 SPF 测试返回了 softfail 和 domain of transitioning 。消息详情如下:

Delivered-To: eric.clapton@gmail.com
Received: by 10.50.73.42 with SMTP id i10csp74854igv;
    Mon, 7 Oct 2013 03:21:52 -0700 (PDT)
X-Received: by 10.68.44.33 with SMTP id b1mr2455965pbm.53.1381141311313;
    Mon, 07 Oct 2013 03:21:51 -0700 (PDT)
Return-Path: <craig@abc.com>
Received: from mtarelay2.ops.gq1.yahoo.net (mtarelay2.ops.gq1.yahoo.net. [98.136.240.39])
    by mx.google.com with ESMTP id f6si4349525pba.278.1969.12.31.16.00.00;
    Mon, 07 Oct 2013 03:21:51 -0700 (PDT)
Received-SPF: softfail (google.com: domain of transitioning craig@abc.com does not     designate 98.136.240.39 as permitted sender) client-ip=98.136.240.39;
Authentication-Results: mx.google.com;
   spf=softfail (google.com: domain of transitioning craig@abc.com does not designate 98.136.240.39 as permitted sender) smtp.mail=craig@abc.com
Received: from p10db3.geo.gq1.yahoo.com (p10db3.geo.gq1.yahoo.com [67.195.61.18])
by mtarelay2.ops.gq1.yahoo.net (Postfix) with ESMTP id 764E0511EB
for <eric.clapton@gmail.com>; Mon,  7 Oct 2013 10:21:35 +0000 (UTC)
Received: (from root@localhost)
by p10db3.geo.gq1.yahoo.com (8.14.4/8.14.4/Submit) id r97ALZiJ005899;
Mon, 7 Oct 2013 03:21:35 -0700
Date: Mon, 7 Oct 2013 03:21:35 -0700
Message-Id: <201310071021.r97ALZiJ005899@p10db3.geo.gq1.yahoo.com>
To: eric.clapton@gmail.com
Subject: Client invoice
From: craig@abc.com
MIME-Version: 1.0

我的域的 SPF 设置是:

v=spf1 a mx ~all 

【问题讨论】:

    标签: dns php spf


    【解决方案1】:

    检查允许哪些 IP 从发件人域发送电子邮件。该网站可让您查看所有允许的 IP: http://spf.myisp.ch

    如果发件人 IP 与它显示的任何 IP 或 IP 范围都不匹配,那么您可能需要编辑 SPF 设置。

    【讨论】:

    • 我检查了那个链接,它是这样说的:allow if the IP matches an A or AAAA record of abc.com 67.195.61.65 allow if the IP matches an MX record of abc.com mx-biz.mail.am0.yahoodns.net. 98.139.171.245 soft deny all IPs which do not match any previous rule
    • 将mtarelay2.ops.gq1.yahoo.net 添加到我的域的MX 记录可以解决此问题吗? mtarelay2.ops.gq1.yahoo.net 似乎是来自成绩单详情的发件人
    • 据我了解,您使用 Yahoo 的网络托管服务,并且希望能够从 yahoo 网络服务器和电子邮件客户端发送电子邮件。我说的对吗?
    • 1.您的 SPF 条目需要包括发送您的电子邮件的邮件服务器(邮件托管商)的所有 IP 地址。
    • 2.您的 SPF 条目必须包含您的网络服务器发送电子邮件的所有 IP。
    【解决方案2】:

    突出的一点是Received: (from root@localhost),它肯定会报错。许多垃圾邮件拦截器,包括谷歌,不允许 localhost 位于 HELO 字符串中。我刚刚在使用 Postfix 的 Ubuntu 服务器上遇到了同样的错误,解决方案是编辑 /etc/postfix/main.cf 以拥有:

    myhostname = abc.com
    

    然后重启postfix服务。

    sudo nano /etc/postfix/main.cf
    sudo /etc/init.d/postfix restart
    

    【讨论】:

      猜你喜欢
      • 1970-01-01
      • 2015-03-12
      • 1970-01-01
      • 2013-12-25
      • 2011-10-02
      • 1970-01-01
      • 2015-02-14
      • 1970-01-01
      • 1970-01-01
      相关资源
      最近更新 更多