【发布时间】:2009-07-24 00:34:13
【问题描述】:
在 SQL Server Management Studio 中运行以下查询会出现以下错误。
update table_name set is_active = 0 where id = 3
当前命令发生严重错误。结果(如果有)应丢弃。
- 日志已被截断
- 有一个更新触发器,但这不是问题
- 事务计数为零 (@@trancount)
我已经在数据库中的其他几个表上尝试了相同的更新语句,它们工作正常。
DBCC CHECKTABLE('table_name');
给予
DBCC results for 'table_name'.
There are 13 rows in 1 pages for object "table_name".
DBCC execution completed. If DBCC printed error messages, contact your system administrator.
【问题讨论】:
-
就我而言,发生这种情况是因为我的磁盘空间不足,并且数据库没有空间用于表中的更改以及添加到事务日志中-磁盘。
标签: sql-server sql-server-2005 tsql