【问题标题】:Unicorn web server won't start after changing ruby version更改 ruby​​ 版本后,独角兽 Web 服务器无法启动
【发布时间】:2014-01-18 13:16:12
【问题描述】:

我使用 ubuntu 12.04 和 rails 4.0.2 在 digitalocean 中创建了一个新的 droplet,问题是我们需要将 rails 降级到 3.2,我做到了。但是当我尝试启动独角兽时,我得到以下信息:

* 启动 Unicorn 网络服务器 unicorn start-stop-daemon:无法统计 /usr/local/rvm/gems/ruby-2.0.0-p353/bin/unicorn(没有这样的文件或目录)强>

我有 Rails 3.2 和 ruby​​ 1.9.3-p484。

【问题讨论】:

  • 没关系,我发现了问题,我需要编辑/etc/init.d/unicorn中的GEM_HOME和GEM_PATH,之后它可以工作了。
  • 请检查您的 unicorn.error.log 文件以了解错误。

标签: ruby-on-rails ruby ruby-on-rails-3 unicorn


【解决方案1】:

来自提问者的评论:

"编辑 /etc/init.d/unicorn 中的 GEM_HOME 和 GEM_PATH,之后它就可以工作了。"

【讨论】:

    猜你喜欢
    • 1970-01-01
    • 2013-07-02
    • 2012-06-01
    • 2023-03-23
    • 1970-01-01
    • 2011-08-08
    • 1970-01-01
    • 2023-03-09
    相关资源
    最近更新 更多