【问题标题】:Unicorn + NGINX: cannot start unicornUnicorn + NGINX:无法启动独角兽
【发布时间】:2023-03-09 08:40:01
【问题描述】:

我刚开始使用 Unicorn 和 NGINX 设置(任何完整的参考资料将不胜感激。我已经在谷歌上爬了三天,并编译了我必须让我的服务器在机架空间中运行的东西)。

继续我的问题。看起来我希望正确地设置 NGINX 以指向我的 rails 应用程序的目录。它能够显示 500 错误页面。现在我正在启动独角兽

unicorn_rails -c /home/deployer/public_html/app/config/unicorn.rb

它给了我这个错误

/home/deployer/.rvm/gems/ruby-1.9.3-p0/gems/unicorn-4.1.1/lib/unicorn/socket_helper.rb:144:in `initialize': Permission denied - bind(2) (Errno::EACCES)
    from /home/deployer/.rvm/gems/ruby-1.9.3-p0/gems/unicorn-4.1.1/lib/unicorn/socket_helper.rb:144:in `new'
    from /home/deployer/.rvm/gems/ruby-1.9.3-p0/gems/unicorn-4.1.1/lib/unicorn/socket_helper.rb:144:in `bind_listen'

我正在尝试在端口 80 上启动应用程序,我知道我需要超级用户权限才能绑定到低于 1024 的任何内容。但是当我尝试使用 sudo 时,它给了我

sudo: unicorn_rails: command not found

任何帮助将不胜感激!

【问题讨论】:

    标签: ruby-on-rails ruby-on-rails-3 nginx unicorn


    【解决方案1】:

    试试rvmsudo unicorn_rails -c /home/deployer/public_html/app/config/unicorn.rb

    【讨论】:

      猜你喜欢
      • 2012-06-01
      • 2023-03-23
      • 1970-01-01
      • 1970-01-01
      • 2011-08-08
      • 1970-01-01
      • 2013-01-10
      • 1970-01-01
      相关资源
      最近更新 更多