【发布时间】:2013-02-21 10:43:28
【问题描述】:
我想尝试限制对基于 IP 的“云服务”的 webrole 的访问。 this article 中有一个很好的文档,但是当我遵循它时,我在部署它时遇到错误。
我得到的错误是:Recycling (Role has encountered an error and has stopped. Application startup task failed with exit code 1
这是错误的部分
%windir%\system32\inetsrv\AppCmd.exe unlock config -section:system.webServer/security/ipSecurity
所以我认为命令是错误的,我在 Windows 2012 操作系统上运行 Webrole。
当只添加 web.config 部分时,没有任何变化,它不起作用
<system.webServer>
<security>
<!—Unlisted IP addresses are denied access–>
<ipSecurity allowUnlisted=”false”>
<!—The following IP addresses are granted access–>
<add allowed=”true” ipAddress=”192.168.100.1” subnetMask=”255.255.0.0″ />
<add allowed=”true” ipAddress=”192.168.100.2″ subnetMask=”255.255.0.0″ />
</ipSecurity>
</security>
</system.webServer>
有没有这方面的经验,谁能帮帮我?
【问题讨论】:
标签: azure azure-web-roles ip-restrictions