【问题标题】:'imagick' Module already loaded every time I run php每次我运行 php 时都已经加载了“imagick”模块
【发布时间】:2019-04-08 17:12:45
【问题描述】:

我的服务器出现问题,每次运行 php 命令时,我都会在错误日志中显示PHP Warning: Module 'imagick' already loaded in Unknown on line 0

我知道这是因为模块在某处被多次加载。

所以我四处寻找,发现我有三个 .ini 文件加载与 extenstion=imagick.so 相同的模块。

imagick.ini
zzzzzzz-pecl.ini
zzzzzzz-pecl.ini.rpmsave

如果这些.ini 位于我的php.d 中

我遇到的问题是我可以在哪里解决这个问题。我知道 pecl 与 imagick 有关,但我不确定在哪里可以解决这个问题,所以它会加载一次。

【问题讨论】:

    标签: php error-handling ini


    【解决方案1】:

    检查所有其他 .ini 文件并删除除 imagick.ini 之外的每个 .ini 文件中的“extension=imagick.so”行。

    然后重启apache。

    【讨论】:

      猜你喜欢
      • 1970-01-01
      • 2010-09-20
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 2018-09-29
      • 2023-04-02
      相关资源
      最近更新 更多