【发布时间】:2017-08-27 12:20:01
【问题描述】:
当我在 Visual Studio 中运行我的 web 应用程序时出现错误页面的原因是什么。网址是http://localhost:5000/ HTTP 错误 403.14 - 禁止 Web 服务器配置为不列出该目录的内容。
【问题讨论】:
标签: visual-studio iis
当我在 Visual Studio 中运行我的 web 应用程序时出现错误页面的原因是什么。网址是http://localhost:5000/ HTTP 错误 403.14 - 禁止 Web 服务器配置为不列出该目录的内容。
【问题讨论】:
标签: visual-studio iis
原因:http://localhost:5000 指的是网络服务器的根。因此,对于上述请求,它会尝试读取服务器的根文件夹。但是,默认情况下 IIS (express) 不允许您查看文件系统。因此它显示上述错误。
您很可能不需要访问服务器的根目录,而是可能需要访问您的 web 应用程序(例如:http://localhost:5000/myapp)。
但是,如果您确切知道自己在做什么,那么您可以使用应用程序的 Web.config 中的以下配置启用 IIS 以显示根目录(文件系统)
重要提示:以下配置不应在生产环境或任何环境中激活 可公开访问的环境,这显然是一个高度关键的环境 安全问题。
<system.webServer>
<directoryBrowse enabled="true" />
<modules runAllManagedModulesForAllRequests="true"></modules>
</system.webServer>
【讨论】:
当我收到此错误时,通常有两个问题:
第一个:我从未定义过标准文档并在某些时候对其进行了更改 - 因此在这种情况下由 IIS 自动定义的标准文档不存在
第二个:我没有启用索引搜索
您可能想试试这个。您可以直接在 IIS 设置中更改这些设置。
【讨论】: