【问题标题】:improper killing of mysqld - now not startingmysqld 的不当杀戮 - 现在无法启动
【发布时间】:2014-09-10 12:29:57
【问题描述】:

我通过杀死进程 id 停止了 mysqld,然后也删除了 mysqld.sock 文件。 现在,mysqld 没有启动。

我知道有一些数据损坏。但是现在我需要在不重新安装的情况下启动 MySQL。

以下是生成的日志。

InnoDB:使用相同的 InnoDB 数据或日志文件。 InnoDB:无法锁定 ./ibdata1,错误:11 InnoDB:检查您是否还没有另一个 mysqld 进程 InnoDB:使用相同的 InnoDB 数据或日志文件。 140107 8:27:43 InnoDB:无法打开第一个数据文件 InnoDB:打开 ./ibdata1 时出错 140107 8:27:43 InnoDB:文件操作中的操作系统错误号 11。 InnoDB:错误号 11 表示“资源暂时不可用”。 InnoDB:一些操作系统错误号在 InnoDB:http://dev.mysql.com/doc/refman/5.1/en/operating-system-error-codes.html InnoDB:无法打开或创建数据文件。 InnoDB:如果您尝试添加新的数据文件,但这里失败了, InnoDB:您现在应该在 my.cnf 中编辑 innodb_data_file_path InnoDB:恢复原状,并删除 InnoDB 创建的新 ibdata 文件 InnoDB:在这次失败的尝试中。 InnoDB 只写了那些满 InnoDB:零,但尚未以任何方式使用它们。但要小心:不要 InnoDB:删除包含您宝贵数据的旧数据文件! 140107 8:27:43 [错误] 插件“InnoDB”初始化函数返回错误。 140107 8:27:43 [错误] 插件“InnoDB”注册为存储引擎失败。 140107 8:27:43 [错误] /usr/libexec/mysqld: 未知选项'--ndbcluster' 140107 8:27:43 [错误] 中止 140107 8:27:43 [注意] /usr/libexec/mysqld:关机完成 140107 08:27:43 来自 pid 文件 /var/run/mysqld/mysqld.pid 的 mysqld_safe mysqld 结束

【问题讨论】:

    标签: mysql kill


    【解决方案1】:

    你需要恢复innodb数据文件。

    # cd /var/lib/mysql
    # mkdir bak
    # mv ibdata1 bak/
    # mv ib_logfile* bak/
    # cp -a bak/ibdata1 ibdata1
    # cp -a bak/ib_logfile* .
    # rm -rf bak
    # service mysqld restart
    

    参考:http://notesonit.blogspot.hk/2013/05/innodb-unable-to-lock-ibdata1-error-11.html

    【讨论】:

    • 嗨,克里斯。感谢你的回复。这次我得到了不同的错误。请在下面的评论中查看错误。
    • 小心!服务器已启动,但是!!!现在我有MySQL said: Table 'any_database.any_table' doesn't exist
    【解决方案2】:

    哇。我遇到了这个问题,因为那是一个清晨,我的大脑没有工作。我正在执行以下操作:

     sudo mysqld -u root -p
    

    当我应该做的时候:

     sudo mysql -u root -p
    

    希望这可以帮助像我一样度过一个艰难早晨的其他人..哈哈

    【讨论】:

      猜你喜欢
      • 1970-01-01
      • 1970-01-01
      • 2017-03-06
      • 1970-01-01
      • 2017-02-28
      • 2012-12-20
      • 2014-08-22
      • 2015-08-25
      • 1970-01-01
      相关资源
      最近更新 更多