【发布时间】:2021-06-10 07:02:23
【问题描述】:
当我尝试启动 Dataflow SQL 作业时出现以下错误:
无法启动 VM,launcher-____,用于启动,因为状态代码:INVALID_ARGUMENT,原因:错误:消息:字段 'resource.networkInterfaces[0].network' 的值无效:'global/networks/default '。找不到引用的网络资源。 HTTP 代码:400。
这个问题今天才开始。
【问题讨论】:
-
您能否检查您的 VPC 网络,看看网络
default是否仍然可用? -
default网络在我收到错误的项目中不存在。当我在另一个拥有default的项目中尝试它时,它似乎正在工作。谢谢!我不确定是什么设置了这个default网络。 -
首次创建项目时默认网络可用。可能是其他人删除了网络配置。要使 Dataflow 正常工作,它需要网络:cloud.google.com/dataflow/docs/guides/specifying-networks。您可以按照此处的说明:cloud.google.com/vpc/docs/using-vpc#creating_networks 为该项目创建一个新网络。
-
或者您可以检查您的组织是否创建了共享 VPC 网络。如果您组织中的某个人正在从事此类工作,他们可能在某处为网络创建了一个宿主项目,这可能就是该项目中的默认网络被删除的原因。
-
谢谢!超级有帮助。