补充:由于SAE对文件权限的限制,cache目录无法修改权限,因此原版Codeigniter无法直接使用。可以尝试http://code.google.com/p/ci-sae/。

在database.php中配置如下:

$db['default']['hostname'] = SAE_MYSQL_HOST_M;
$db['default']['username'] = SAE_MYSQL_USER;
$db['default']['password'] = SAE_MYSQL_PASS;
$db['default']['database'] = SAE_MYSQL_DB;
$db['default']['dbdriver'] = 'mysqli';
$db['default']['dbprefix'] = '';
$db['default']['pconnect'] = FALSE;
$db['default']['db_debug'] = TRUE;
$db['default']['cache_on'] = FALSE;
$db['default']['cachedir'] = '';
$db['default']['char_set'] = 'utf8';
$db['default']['dbcollat'] = 'utf8_general_ci';
$db['default']['swap_pre'] = '';
$db['default']['autoinit'] = TRUE;
$db['default']['stricton'] = FALSE;
$db['default']['port'] = SAE_MYSQL_PORT;

注意其中高亮的部分,不然会出现如下的错误提示:

A Database Error Occurred

Unable to connect to your database server using the provided settings.

Filename: core/Loader.php

Line Number: 346

相关文章:

  • 2021-09-28
  • 2021-12-18
  • 2022-12-23
  • 2021-08-25
  • 2022-12-23
  • 2021-05-04
  • 2021-12-02
  • 2021-12-02
猜你喜欢
  • 2021-05-19
  • 2021-07-21
  • 2021-06-30
  • 2021-11-27
  • 2021-09-26
  • 2021-05-24
  • 2021-05-18
相关资源
相似解决方案