运行SQL文件报错

1273 - Unknown collation: 'utf8mb4_0900_as_ci'

 

 

 错误原因:高版本数据库(8.0)转存sql文件 并导入低版本数据库(5.7)造成。

 

解决办法:

方案一:升级mysql至高版本

方案二:打开需要导入的sql文件,将文件中的

utf8mb4_0900_ai_ci全部替换为utf8_general_ci
utf8mb4替换为utf8

再次执行SQL文件

相关文章:

  • 2022-12-23
  • 2021-05-13
  • 2021-12-13
  • 2022-12-23
  • 2021-09-15
  • 2022-01-06
  • 2021-08-14
猜你喜欢
  • 2022-03-02
  • 2021-09-26
  • 2022-01-09
  • 2021-10-11
  • 2021-05-12
相关资源
相似解决方案