昨天在用sudo命令执行mkdir命令的时候发生了错误。错误提示如下:

hadoop@master:/home$ sudo mkdir /home/hadoop
[sudo] password for hadoop: 
hadoop is not in the sudoers file.  This incident will be reported.

 

原因是当前用户没有借用root权限去执行后面命令的权限,默认是只有admin组的成员才有这个权限的。那是在哪设定这个东西的呢?

答案就是visudo命令进入/etc/sudoers文件的编辑模式去设定(需要以root用户)。

添加下面这条记录

<user_name>    ALL=(ALL) ALL

比如:

# User privilege specification
root    ALL=(ALL:ALL) ALL
hadoop ALL=(ALL) ALL

意思让用户hadoop可以取得root权限去做任何事情

 

参考:

How do I add myself into the sudoers group?

相关文章:

  • 2021-08-23
  • 2021-05-18
  • 2022-03-07
  • 2022-03-06
  • 2022-02-20
  • 2021-12-18
  • 2021-10-18
  • 2021-10-10
猜你喜欢
  • 2022-01-02
  • 2021-07-08
  • 2021-07-15
  • 2021-12-03
  • 2021-12-16
  • 2022-12-23
  • 2022-12-23
相关资源
相似解决方案