1、问题描述:

今天突然PHP同事给我说预发布的mongo挂了,我上去看了一下日志显示:

mongodb服务挂了重启日志报错Out of memory

原因:

mongodb服务挂了重启日志报错Out of memory

同事说他建了个索引,然后mongo就挂了,由于mongodb的重建索引的时候,吃掉所有内存,导致mongodb进程被杀掉。

 

2、解决方法:

方法一:要么增加服务器内存

方法二:要么删除一些索引,开启服务之前为了重建成功启动,先注释参数wiredTigerCacheSizeGB=6,然后删索引后再配置这个参数启动mongo

 

相关文章:

  • 2022-12-23
  • 2022-01-30
  • 2021-09-28
  • 2021-11-23
  • 2021-07-02
  • 2021-08-15
  • 2022-12-23
猜你喜欢
  • 2021-06-16
  • 2021-06-29
  • 2021-12-21
  • 2022-12-23
  • 2021-08-21
  • 2022-02-26
  • 2021-10-25
相关资源
相似解决方案