【问题标题】:AWS Lake Formation: Insufficient Lake Formation permission(s) on s3://abc/AWS Lake Formation:s3://abc/ 上的 Lake Formation 权限不足
【发布时间】:2022-03-22 18:25:03
【问题描述】:
【问题讨论】:
标签:
amazon-web-services
amazon-s3
aws-lake-formation
【解决方案1】:
由于错误状态“s3 上的 Lake Formation 权限不足”
这意味着您必须授予您的角色/用户访问 s3 存储桶的权限。
首先你必须去 "Lake Formation" => 在 "Permissions" 选项卡下 => 选择 "Data locations" 然后注册您的 S3 位置。
完成此步骤后,您可以创建数据库。
【解决方案2】:
如果您已将某些资源(IAM 角色/用户)声明为 Lake Formation 管理员,您将无法从 Lake Formation 控制台创建 Glue 数据库,即使您拥有 AWS 账户管理员访问权限。如果您尝试使用 Lake Formation 管理员资源权限进行创建,它将起作用。
【解决方案3】:
如果您使用 SageMaker,在查询 Athena 时遇到“AWS Lake Formation: Insufficient Lake Formation permission(s) on temp s3:// ... AWS Glue”。您应该在 LakeFormation 中检查“Datalake 权限”,授予资源数据库“sagemaker_data_wrangler”的执行角色具有完全权限。这是因为 SageMaker 在查询 Athena 时,会将其临时结果存储在 Glue 的数据库“sagemaker_data_wrangler”中,因此它没有足够的权限在其中存储临时数据。
更多信息:https://github.com/awslabs/aws-data-wrangler/issues/677