【问题标题】:Filebeat > Logstash > ElasticSearch - Lumberjack ErrorFilebeat > Logstash > ElasticSearch - 伐木工人错误
【发布时间】:2016-11-30 16:45:35
【问题描述】:

试图让 Filebeat 与 logstash 一起工作。目前我收到此错误:

2016/11/14 04:54:27.721478 output.go:109: DBG  output worker: publish 2047 events
2016/11/14 04:54:27.756650 sync.go:85: ERR Failed to publish events caused by: lumberjack protocol error
2016/11/14 04:54:27.756676 single.go:91: INFO Error publishing events (retrying): lumberjack protocol error
2016/11/14 04:54:28.782729 sync.go:85: ERR Failed to publish events caused by: lumberjack protocol error
2016/11/14 04:54:28.782756 single.go:91: INFO Error publishing events (retrying): lumberjack protocol error
2016/11/14 04:54:30.786983 sync.go:85: ERR Failed to publish events caused by: lumberjack protocol error
2016/11/14 04:54:30.787017 single.go:91: INFO Error publishing events (retrying): lumberjack protocol error
2016/11/14 04:54:34.808528 sync.go:85: ERR Failed to publish events caused by: lumberjack protocol error
2016/11/14 04:54:34.808578 single.go:91: INFO Error publishing events (retrying): lumberjack protocol error

有没有人有解决方案,或者您可以指出正确的方向?

Filebeat v5 和 logstash v5。

在本地进行。

谢谢!

【问题讨论】:

  • 你能发布你的 filebeat 和 logstash 配置吗?您是否在两者之间设置了任何类型的身份验证?

标签: elasticsearch logstash filebeat


【解决方案1】:

这可能是因为您的 logstash 对您的 filebeat 不可见。 请在节拍上启动您的 logstash 作为输入。我已经在端口号 31311 上启动了我的 logstash。

    input {
  beats {
    host => "0.0.0.0"
    port => 31311
  }
}

filebeat.yml 中的配置:默认情况下是 ElasaticSearch 输出。请注释它并取消注释logstash 输出配置。它应该如下所示。

output.logstash:
  # The Logstash hosts
  hosts: ["localhost:31311"]

请注意您是否在这两者之间设置了任何身份验证。 完成此配置后,我可以在 logstash 中看到我的消息,最后在 Kibana 中看到我的消息。希望它会起作用。

【讨论】:

  • 大家好,感谢您的回答!我让它工作。这是不正确的主机和端口。
  • 我想问一下如何打开这个logstash端口?在 logstash.yml 文件中,端口是在哪里指定的?
猜你喜欢
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 2012-03-07
  • 1970-01-01
  • 1970-01-01
相关资源
最近更新 更多