【问题标题】:Is it possible to run the elk stack on kubernetes using minikube是否可以使用 minikube 在 kubernetes 上运行 elk 堆栈
【发布时间】:2020-02-19 19:09:01
【问题描述】:

我正在尝试使用 minikube 在 linux ubuntu 18.04 笔记本电脑上本地运行 elk 堆栈。 但是我没有通过第一步,Elastiarch 主节点没有上线。显然是因为物理卷没有被创建,或者不能被使用。我的简短问题是 minikube 是否被支持作为运行 kibana/elastisearch/logstach 的一种方式,或者它们是否只是为了在云中运行。 我一直在关注本教程:

https://logz.io/blog/deploying-the-elk-stack-on-kubernetes-with-helm/

Running pods
NAME                                          READY   STATUS                  RESTARTS   AGE
elk-elasticsearch-client-5ffc974f8-987zv      1/1     Running                 0          21m
elk-elasticsearch-curator-1582107120-4f2wm    0/1     Completed               0          19m
elk-elasticsearch-data-0                      0/1     Pending                 0          21m
elk-elasticsearch-exporter-84ff9b656d-t8vw2   1/1     Running                 0          21m
elk-elasticsearch-master-0                    1/1     Running                 0          21m
elk-elasticsearch-master-1                    1/1     Running                 0          20m
elk-filebeat-4sxn9                            0/2     Init:CrashLoopBackOff   9          21m
elk-kibana-77b97d7c69-d4jzz                   1/1     Running                 0          21m
elk-logstash-0                                0/2     Pending                 0          21m

所以我尝试做的 filebeat 不会为我启动 kubectl 记录 elk-filebeat-4sxn9 加载-es-模板

我从中得到:

退出:无法连接到任何已配置的 Elasticsearch 主机。错误:[与 Elasticsearch http://elk-elasticsearch-client.elk.svc:9200 的连接错误:获取 http://elk-elasticsearch-client.elk.svc:9200:在 10.96.0.10:53 上查找 elk-elasticsearch-client.elk.svc:没有这样的主机]

【问题讨论】:

    标签: minikube elk


    【解决方案1】:

    嗯,是的,您可以使用minikube,但您需要使用正确的选项进行安装。

    请记住,这是不推荐。

    在Elastic 文档中关于Production Deployment - Hardware 我们可以阅读:

    • MEMORY

      具有 64 GB RAM 的机器是理想的最佳选择,但 32 GB 和 16 GB 的机器也很常见。小于 8 GB 往往会适得其反

      Minikube by deafault only allocates 2GB of RAM,您可以通过$ minikube config get memory查看。您可以通过使用--memory 标志或使用$ minikube config set memory 4096 使其持久化来增加此值

    • CPU

      这不是一个真正的问题,因为:

      大多数 Elasticsearch 部署往往对 CPU 要求相当轻。因此,确切的处理器设置比其他资源更重要。您应该选择具有多核的现代处理器。常见集群使用两到八核机器。

    • DISKS

      它们很重要,通常是集群中的主要瓶颈。

      如果您买得起 SSD,那么它们远远优于任何旋转介质。 SSD 支持的节点在查询和索引性能方面都有所提升。如果您负担得起,SSD 是您的最佳选择。

      ...

      如果您使用旋转介质,请尽量获得最快的磁盘(高性能服务器磁盘、15k RPM 驱动器)。

      对于旋转磁盘和 SSD,使用 RAID 0 是提高磁盘速度的有效方法。无需使用 RAID 的镜像或奇偶校验变体,因为 Elasticsearch 通过副本内置了高可用性。

    这些是与 ELK 相关的基本内容。您可以阅读ELK Architecture and requirements 和Hardware requirement ELK 了解有关数据消耗的更多详细信息。

    您需要共享来自pods 和minikube 配置的日志,以便我们开始调试问题。

    【讨论】:

    • @Tobbes,您没有发布任何内容。请编辑问题并将其添加到那里。
    • 我在上面添加了一些日志。可能是我运行的 RAM 太少,总数为:11964,而我在 minikube 上运行的是 4096。但是,在这种情况下,我希望收到一条智能错误消息。
    • 我相信我现在做到了。
    • @Tobbes,您应该将此错误作为一个单独的问题发布,因为它与您的主要问题无关。
    猜你喜欢
    • 2020-06-03
    • 1970-01-01
    • 1970-01-01
    • 2021-11-05
    • 1970-01-01
    • 1970-01-01
    • 2019-05-09
    • 2021-10-01
    • 2017-08-20
    相关资源
    最近更新 更多