【发布时间】:2020-02-19 19:09:01
【问题描述】:
我正在尝试使用 minikube 在 linux ubuntu 18.04 笔记本电脑上本地运行 elk 堆栈。 但是我没有通过第一步,Elastiarch 主节点没有上线。显然是因为物理卷没有被创建,或者不能被使用。我的简短问题是 minikube 是否被支持作为运行 kibana/elastisearch/logstach 的一种方式,或者它们是否只是为了在云中运行。 我一直在关注本教程:
https://logz.io/blog/deploying-the-elk-stack-on-kubernetes-with-helm/
Running pods
NAME READY STATUS RESTARTS AGE
elk-elasticsearch-client-5ffc974f8-987zv 1/1 Running 0 21m
elk-elasticsearch-curator-1582107120-4f2wm 0/1 Completed 0 19m
elk-elasticsearch-data-0 0/1 Pending 0 21m
elk-elasticsearch-exporter-84ff9b656d-t8vw2 1/1 Running 0 21m
elk-elasticsearch-master-0 1/1 Running 0 21m
elk-elasticsearch-master-1 1/1 Running 0 20m
elk-filebeat-4sxn9 0/2 Init:CrashLoopBackOff 9 21m
elk-kibana-77b97d7c69-d4jzz 1/1 Running 0 21m
elk-logstash-0 0/2 Pending 0 21m
所以我尝试做的 filebeat 不会为我启动 kubectl 记录 elk-filebeat-4sxn9 加载-es-模板
我从中得到:
退出:无法连接到任何已配置的 Elasticsearch 主机。错误:[与 Elasticsearch http://elk-elasticsearch-client.elk.svc:9200 的连接错误:获取 http://elk-elasticsearch-client.elk.svc:9200:在 10.96.0.10:53 上查找 elk-elasticsearch-client.elk.svc:没有这样的主机]
【问题讨论】: