【问题标题】:Minikube failed to start -> pgrep kube-apiMinikube 无法启动 -> pgrep kube-api
【发布时间】:2019-11-29 09:24:53
【问题描述】:

我正在使用 kubernetes 和 minukube 在我的机器上本地运行一个集群,但我得到了这个错误:

W1118 20:54:48.711968 14383 kubeadm.go:502] pgrep apiserver: command failed: sudo pgrep kube-apiserver
stdout:
stderr: : exit status 1 cmd: sudo pgrep kube-apiserver
I1118 20:54:49.012735 14383 exec_runner.go:42] (ExecRunner) Run: sudo pgrep kube-apiserver
I1118 20:54:49.041602 14383 exec_runner.go:74] (ExecRunner) Non-zero exit: sudo pgrep kube-apiserver: exit status 1 (28.808764ms)
W1118 20:54:49.041655 14383 kubeadm.go:502] pgrep apiserver: command failed: sudo pgrep kube-apiserver
stdout:
stderr: : exit status 1 cmd: sudo pgrep kube-apiserver
I1118 20:54:49.332086 14383 exec_runner.go:42] (ExecRunner) Run: sudo pgrep kube-apiserver
I1118 20:54:49.354256 14383 exec_runner.go:74] (ExecRunner) Non-zero exit: sudo pgrep kube-apiserver: exit status 1 (22.079013ms)
W1118 20:54:49.354306 14383 kubeadm.go:502] pgrep apiserver: command failed: sudo pgrep kube-apiserver
stdout:
stderr: : exit status 1 cmd: sudo pgrep kube-apiserver
I1118 20:54:49.612700 14383 exec_runner.go:42] (ExecRunner) Run: sudo pgrep kube-apiserver
I1118 20:54:49.630745 14383 exec_runner.go:74] (ExecRunner) Non-zero exit: sudo pgrep kube-apiserver: exit status 1 (17.984732ms)
W1118 20:54:49.630837 14383 kubeadm.go:502] pgrep apiserver: command failed: sudo pgrep kube-apiserver

我正在调查它,但我没有发现任何与它相关的东西。

【问题讨论】:

  • 您使用哪种操作系统?
  • 我正在使用 ubuntu
  • 你正在使用 sudo 运行 minikube,因为它看起来缺少 perms

标签: kubernetes minikube


【解决方案1】:

使用您提供的信息,检查您的主机配置,因为它看起来需要权限,然后运行:

echo "1" >/proc/sys/net/bridge/bridge-nf-call-iptables

这修改了您的操作系统以启用桥接调用

【讨论】:

    猜你喜欢
    • 2018-11-13
    • 2020-03-13
    • 2021-05-16
    • 1970-01-01
    • 2023-03-10
    • 2019-11-19
    • 2021-04-14
    • 2019-10-23
    • 1970-01-01
    相关资源
    最近更新 更多