【问题标题】:Zip Deployment fails with "Unhandled exception. System.IO.IOException: Disk quota exceeded"Zip 部署失败,出现“未处理的异常。System.IO.IOException:超出磁盘配额”
【发布时间】:2020-08-28 04:54:47
【问题描述】:

使用 zip deploy 将 Azure 函数部署到 Azure 时出现错误。我在VSTS中看到的错误不是很详细,但它表明zip部署失败。

##[error]Failed to deploy web package to App Service.

##[error]To debug further please check Kudu stack trace URL : https://my-path/**/trace

##[error]Error: Error: Failed to deploy web package to App Service. Internal Server Error (CODE: 500)   

查看默认的 docker 错误转储,我看到了更多详细信息。显然存在磁盘配额问题,但我检查了我的存储帐户,它只使用了 5000 GB 中的 3GB。

部署日志中的详细信息可以在下面找到:

Starting OpenBSD Secure Shell server: sshd.
Unhandled exception. System.IO.IOException: Disk quota exceeded
   at System.IO.Enumeration.FileSystemEnumerator`1.FindNextEntry(Byte* entryBufferPtr, Int32 bufferLength)
   at System.IO.Enumeration.FileSystemEnumerator`1.MoveNext()
   at System.IO.FileSystemWatcher.RunningInstance.AddDirectoryWatchUnlocked(WatchedDirectory parent, String directoryName)
   at System.IO.FileSystemWatcher.RunningInstance.AddDirectoryWatchUnlocked(WatchedDirectory parent, String directoryName)
   at System.IO.FileSystemWatcher.RunningInstance.AddDirectoryWatchUnlocked(WatchedDirectory parent, String directoryName)
   at System.IO.FileSystemWatcher.RunningInstance..ctor(FileSystemWatcher watcher, SafeFileHandle inotifyHandle, String directoryPath, Boolean includeSubdirectories, NotifyFilters notifyFilters, CancellationToken cancellationToken)
   at System.IO.FileSystemWatcher.StartRaisingEvents()
   at System.IO.FileSystemWatcher.StartRaisingEventsIfNotDisposed()
   at System.IO.FileSystemWatcher.set_EnableRaisingEvents(Boolean value)
   at Microsoft.Extensions.FileProviders.Physical.PhysicalFilesWatcher.TryEnableFileSystemWatcher()
   at Microsoft.Extensions.FileProviders.Physical.PhysicalFilesWatcher.CreateFileChangeToken(String filter)
   at Microsoft.Extensions.FileProviders.PhysicalFileProvider.Watch(String filter)
   at Microsoft.Extensions.Configuration.FileConfigurationProvider.<.ctor>b__1_0()
   at Microsoft.Extensions.Primitives.ChangeToken.ChangeTokenRegistration`1..ctor(Func`1 changeTokenProducer, Action`1 changeTokenConsumer, TState state)
   at Microsoft.Extensions.Primitives.ChangeToken.OnChange(Func`1 changeTokenProducer, Action changeTokenConsumer)
   at Microsoft.Extensions.Configuration.FileConfigurationProvider..ctor(FileConfigurationSource source)
   at Microsoft.Extensions.Configuration.Json.JsonConfigurationSource.Build(IConfigurationBuilder builder)
   at Microsoft.Extensions.Configuration.ConfigurationBuilder.Build()
   at Microsoft.AspNetCore.Hosting.WebHostBuilder.BuildCommonServices(AggregateException& hostingStartupErrors)
   at Microsoft.AspNetCore.Hosting.WebHostBuilder.Build()
   at Microsoft.Azure.WebJobs.Script.WebHost.Program.BuildWebHost(String[] args) in /src/azure-functions-host/src/WebJobs.Script.WebHost/Program.cs:line 35
   at Microsoft.Azure.WebJobs.Script.WebHost.Program.Main(String[] args) in /src/azure-functions-host/src/WebJobs.Script.WebHost/Program.cs:line 25
/azure-functions-host/start.sh: line 28:    18 Aborted                 (core dumped) /azure-functions-host/Microsoft.Azure.WebJobs.Script.WebHost

我们在部署 AZ 功能时需要遵守的磁盘配额是多少?我在应用服务计划或资源组中都看不到任何配额。如上所述,该函数引用的存储帐户远非容量。

作为参考,我的应用程序大小只有 13MB。

在 Azure 门户中,我在概览窗格的红色横幅中看到错误消息“System.Private.CoreLib:磁盘配额超出”。

这个版本已经运行好几个月了。这个问题最近几天开始发生。我相信我们之前已经看到它非常间歇地发生,但目前它几乎每次都发生。如果幸运的话,我们可能会通过十分之一的部署。

函数应用是高级 (EP1) 层中的常规 Linux 函数应用。

【问题讨论】:

  • 这似乎是 Linux 上的一个问题。将函数应用转换为 Windows 解决了这个问题。
  • 您可以添加回复并接受它作为答案,这将有利于其他社区成员阅读此主题。

标签: azure azure-devops azure-functions


【解决方案1】:

这似乎是 Linux 上的一个问题。将函数应用转换为 Windows 解决了该问题。

【讨论】:

    猜你喜欢
    • 2017-11-19
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2022-07-02
    • 2022-08-06
    • 2020-07-28
    • 1970-01-01
    相关资源
    最近更新 更多