【问题标题】:Unable to connect to the server: dial tcp 10.0.0.1:443: i/o timeout error in GKE pod无法连接到服务器:拨打 tcp 10.0.0.1:443:GKE pod 中的 i/o 超时错误
【发布时间】:2021-10-11 11:17:01
【问题描述】:

在 GKE pod 中运行 kubectl get pods 命令时,我们经常收到以下错误。有时,当在 2 个节点上启动 2 个 pod(部署)时,在一个 pod 上,命令成功执行,在另一个 pod 上,该命令在同一 docker 映像上的另一个 pod 上给出以下错误:

  • 无法连接到服务器:拨号 tcp 10.0.0.1:443:i/o 超时

在 GKE 中运行 pods(chaos-mesh master controller:chaos-controller-manager-d945b5d5b-f2pr7) 时,我们也遇到了以下错误,与上面类似:

  • "error": "Get "https://10.0.0.1:443/api?timeout=32s": dial tcp 10.0.0.1:443: i/o timeout"}
  • 未能获取 API 组资源 {"error": "Get "https://10.0.0.1:443/api?timeout=32s": dial tcp 10.0.0.1:443: i/o timeout"}

任何人都可以提出任何解决方案。如您所知,谷歌不提供任何随用随付的支持。这使我们处于非常困难的境地,即使我们付钱,但我们得不到支持。 谢谢

【问题讨论】:

  • 您能否分享有关您的部署的任何其他信息?

标签: google-kubernetes-engine


【解决方案1】:

tldr;请检查 GKE 集群上的防火墙规则、CNI 配置和网络策略。

似乎10.0.0.1:443 是“kubernetes”服务的端点,集群内 pod 访问 kube-apiserver 的服务。问题是某些 Pod 无法访问此端点,很可能是 Pod Networking 配置错误。请确保 CNI 运行良好并且 kube-proxy 创建正确的 iptables 或 lvs 规则

【讨论】:

    猜你喜欢
    • 2021-11-22
    • 1970-01-01
    • 1970-01-01
    • 2018-09-12
    • 2019-08-21
    • 2021-06-11
    • 2019-01-31
    • 1970-01-01
    • 2021-01-23
    相关资源
    最近更新 更多