【问题标题】:Elasticsearch error to start serviceElasticsearch错误启动服务
【发布时间】:2017-02-10 11:49:59
【问题描述】:

我在启动elasticsearch时遇到问题,启动命令是:

cd /etc/init.d && ./elasticsearch start

输出。

/opt/jdk1.8.0_77 uno
JAVA /opt/jdk1.8.0_77/bin/java
Starting elasticsearch:                                    [  OK  ]

但我得到了执行状态:“elasticsearch dead but subsys locked”

我尝试删除 /var/lock/subsys 中的“elasticsearch”,但该文件又生成了。

在日志中说。

java.lang.RuntimeException: Java version: 1.7.0_40 suffers from critical bug https://bugs.openjdk.java.net/browse/JDK-8024830 which can cause data corruption.
Please upgrade the JVM, see http://www.elastic.co/guide/en/elasticsearch/reference/current/_installation.html for current recommendations.
If you absolutely cannot upgrade, please add -XX:-UseSuperWord to the JVM_OPTS environment variable.
Upgrading is preferred, this workaround will result in degraded performance.

但是进程是用java 8启动的,

elasticsearch      26918  0.8  1.0 30526952 724324 ?     Sl   Jul03   1:29 /opt/jdk1.8.0_77/bin/java -Xms256m -Xmx1g -Djava.awt.headless=true -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -XX:+HeapDumpOnOutOfMemoryError -XX:+DisableExplicitGC -Dfile.encoding=UTF-8 -Delasticsearch -Des.foreground=yes -Des.path.home=/opt/elasticsearch -cp :/opt/elasticsearch/lib/elasticsearch-1.7.0.jar:/opt/elasticsearch/lib/*:/opt/elasticsearch/lib/sigar/* org.elasticsearch.bootstrap.Elasticsearch

任何帮助将不胜感激。

【问题讨论】:

  • 使用 ''ps -ef|grep elasticsearch'' 命令输出什么?
  • 弹性搜索 26918 1 0 Jul03 ? 00:03:52 /opt/jdk1.8.0_77/bin/java -Xms256m -Xmx1g -Djava.awt.headless=true -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly - XX:+HeapDumpOnOutOfMemoryError -XX:+DisableExplicitGC -Dfile.encoding=UTF-8 -Delasticsearch -Des.foreground=yes -Des.path.home=/opt/elasticsearch -cp :/opt/elasticsearch/lib/elasticsearch-1.7。 0.jar:/opt/elasticsearch/lib/*:/opt/elasticsearch/lib/sigar/* org.elasticsearch.bootstrap.Elasticsearch

标签: linux elasticsearch java-8 logstash java-7


【解决方案1】:

验证 java 选择

替代方案--config java

确保 java 8 正在使用中。 Elasticsearch 至少需要 Java 8。

请尝试在 /etc/elasticsearch/elasticsearch.yml 中设置变量:

path.data: 路径/到/数据

path.work: path/to/work

path.logs: /var/log/elasticsearch

path.conf: /etc/elasticsearch

注意:授予用户“elasticsearch”访问文件夹的权限 elasticsearch 使用:

chown -R elasticsearch /path/to/data chown -R elasticsearch /path/to/work

【讨论】:

    猜你喜欢
    • 1970-01-01
    • 2017-03-03
    • 2011-07-25
    • 2012-12-01
    • 1970-01-01
    • 1970-01-01
    • 2014-07-01
    • 2019-02-26
    • 2017-06-14
    相关资源
    最近更新 更多