【发布时间】:2021-10-25 19:09:38
【问题描述】:
我发现我的一个容器倒了。这是我第二次遇到这个问题。当我尝试使用 docker start 启动它时,我得到:
来自守护程序的错误响应:无效的标头字段值“oci 运行时 错误:container_linux.go:247:启动容器进程导致 \"process_linux.go:359: 容器初始化导致 \\"rootfs_linux.go:89: rootfs 中的监禁过程导致 \\\\" 无法创建 pivot_root 目录,错误 mkdir /var/lib/docker/devicemapper/mnt/da2101d43e6c8200eb22a4415b0aedf8033c7c701a19392217b8947738a723bf/rootfs/.pivot_root592021975: 设备上没有剩余空间\\\\"\\"\"\n" 错误:启动失败 容器:mydockername
知道为什么我在设备上没有剩余空间吗?主机体积仅占6%。
我使用的是 CentOS Docker 版本 1.12.3,构建 6b644ec
【问题讨论】:
-
您好,可以粘贴
df -h的结果吗?另外,你能用另一张图片测试一下吗? -
主机操作系统是什么?您用来启动/运行映像的命令是什么?
-
您好,我使用 centos-release-7-2.1511.el7.centos.2.10.x86_64(在托管服务提供商中虚拟化)。对不起,卡洛斯,我不能做 df -h。我需要恢复服务,所以我删除了损坏的服务器并创建了它。
-
Rao,我使用简单的 docker run... 没有任何特殊的 frag... 我只使用 -d --name -m --link 标志(我将它链接到其他 docker 中的数据库)。
-
你最后找到解决办法了吗?