【问题标题】:Failed Kinesis Spout (Apache Storm)失败的 Kinesis Spout (Apache Storm)
【发布时间】:2015-11-27 02:11:47
【问题描述】:

我一直在对我们的 Apache Storm 拓扑进行性能测试,并注意到来自 kinesis-spout 的“失败”计数非常高(几乎 1/3 的元组被确认)。这个值是多少?

它们是在超时值内未能在拓扑中端到端处理的元组吗?有没有办法验证失败计数是由于处理超时造成的?

【问题讨论】:

    标签: apache-storm


    【解决方案1】:

    是的,失败计数显示失败(即,未端到端处理)元组的数量。元组失败可能有两个原因。元组因用户代码失败(通过调用Collector.fail(...))或元组超时。

    因此,如果不涉及手动失败,则元组失败的原因是超时。 Storm 中的默认超时时间是 30 秒,可以通过Config.TOPOLOGY_MESSAGE_TIMEOUT_SECS 进行配置。

    【讨论】:

    • 谢谢,这是我假设的,因为螺栓没有故障。我会尝试增加超时值。
    猜你喜欢
    • 2020-05-01
    • 1970-01-01
    • 2018-08-14
    • 2015-04-22
    • 2018-09-19
    • 2019-03-14
    • 2016-11-12
    • 1970-01-01
    • 1970-01-01
    相关资源
    最近更新 更多