【发布时间】:2015-08-19 17:34:37
【问题描述】:
我的团队正在亚马逊云上部署一个新的大数据架构。我们已经启动并运行了 Mesos 作业。
我们正在从同一集群内的堡垒主机提交 Spark 作业(即 jars)。但是,这样做的堡垒主机是驱动程序,它被称为client mode(如果我理解正确的话)。
我们想试试cluster mode,但我们不知道从哪里开始调度程序进程。
文档说要在集群中启动它,但我很困惑,因为我们的 master 没有安装 Spark,我们使用 Zookeeper 进行 master 选举。在从节点上启动它不是一个可用的选项,因为从节点可能会失败,而且我们不想将从节点 IP 或公共 DNS 暴露给堡垒主机。
在堡垒主机上启动调度器是否正确?
非常感谢
【问题讨论】:
标签: apache-spark mesos