【问题标题】:Can't start kylin on kerberized cluster无法在 kerberized 集群上启动 kylin
【发布时间】:2017-09-02 21:59:16
【问题描述】:

我已经在CDH集群上成功安装了Kerberos和Sentry(cm-5.8.4),现在我需要使用Apache Kylin做一些数据分析,但是我无法启动Kylin并安装sample.sh。当我尝试运行 sh sample.sh 时,我收到以下错误消息:

2017-08-02 14:44:44,805 信息 [主要] zookeeper.ZooKeeper:客户端 环境:java.library.path=/opt/cloudera/parcels/CDH-5.8.4- 1.cdh5.8.4.p0.5/lib/hadoop/lib/native/:/opt/cloudera/parcels/CDH-5.8.4- 1.cdh5.8.4.p0.5/lib/hadoop/lib/native/:/opt/cloudera/parcels/CDH-5.8.4- 1.cdh5.8.4.p0.5/lib/hadoop/lib/native:/opt/cloudera/parcels/CDH-5.8.4- 1.cdh5.8.4.p0.5/lib/hbase/bin/../lib/native/Linux-amd64-64 2017-08-02 14:44:44,806 INFO [main] zookeeper.ZooKeeper:客户端 环境:java.io.tmpdir=/tmp 2017-08-02 14:44:44,806 信息 [主要] zookeeper.ZooKeeper:客户端环境:java.compiler= 2017-08-02 14:44:44,806 INFO [main] zookeeper.ZooKeeper:客户端 环境:os.name=Linux 2017-08-02 14:44:44,806 信息 [主要] zookeeper.ZooKeeper:客户端环境:os.arch=amd64 2017-08-02 14:44:44,806 INFO [main] zookeeper.ZooKeeper:客户端 环境:os.version=3.10.0-229.el7.x86_64 2017-08-02 14:44:44,806 INFO [main] zookeeper.ZooKeeper:客户端环境:user.name=root 2017-08-02 14:44:44,806 信息 [主要] zookeeper.ZooKeeper:客户端 环境:user.home=/root 2017-08-02 14:44:44,806 信息 [主要] zookeeper.ZooKeeper:客户端 环境:user.dir=/data1/apache-kylin-1.6.0-cdh5.7-bin 2017-08-02 14:44:44,806 INFO [main] zookeeper.ZooKeeper:启动客户端 连接,connectString=localhost:2181 sessionTimeout=90000 观察者=hconnection-0x3cc79c020x0,法定人数=本地主机:2181, baseZNode=/hbase 2017-08-02 14:44:44,823 信息 [main-SendThread(localhost:2181)] zookeeper.ClientCnxn:打开 与服务器 localhost/127.0.0.1:2181 的套接字连接。将不会 尝试使用 SASL 进行身份验证(未知错误)2017-08-02 14:44:44,829 警告 [main-SendThread(localhost:2181)] zookeeper.ClientCnxn:服务器空的会话 0x0,意外错误, 关闭套接字连接并尝试重新连接 java.net.ConnectException:连接被拒绝 在 sun.nio.ch.SocketChannelImpl.checkConnect(Native Method) 在 sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:717) 在 org.apache.zookeeper.ClientCnxnSocketNIO.doTransport(ClientCnxnSocketNIO.java:350) 在 org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1081) 2017-08-02 14:44:45,934 信息 [main-SendThread(localhost:2181)] zookeeper.ClientCnxn:打开到服务器的套接字连接 本地主机/127.0.0.1:2181。不会尝试使用 SASL 进行身份验证 (未知错误)2017-08-02 14:44:45,935 警告 [main-SendThread(localhost:2181)] zookeeper.ClientCnxn: 会话 0x0 对于服务器空、意外错误、关闭套接字连接和 尝试重新连接

有谁知道如何解决这个问题或向我展示在 kerberized 集群上使用 Kylin 的指南?谢谢!

麒麟的版本是apache-kylin-1.6.0-cdh5.7-bin。

【问题讨论】:

    标签: kerberos cloudera-cdh kylin


    【解决方案1】:

    在 kerberized 集群上安装 kylin 非常简单。

    步骤 1. 确保在 cdh 网关上安装 kylin。

    步骤 2. 正确设置环境。

     such as hadoop_home;hive_conf;hbase_conf etc.
    

    步骤 3. 按照 kylin 网站上的安装说明进行操作。

    如果您需要更多帮助,请给我留言,我可以向您展示前两个步骤的更详细文档。

    【讨论】:

      猜你喜欢
      • 1970-01-01
      • 1970-01-01
      • 2017-01-22
      • 2019-01-31
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 2020-05-25
      • 1970-01-01
      相关资源
      最近更新 更多