【发布时间】:2016-10-29 08:24:45
【问题描述】:
【问题讨论】:
标签: azure push-notification azure-notificationhub
【问题讨论】:
标签: azure push-notification azure-notificationhub
【讨论】:
请检查您是否是您尝试在其中创建命名空间的订阅的(共同)管理员。 如果您只是尝试在其中创建命名空间的 ResourceGroup 的所有者,您将收到此误导性错误消息。
原因是:Notification Hub 是基于 Service Bus 实现的,但 Service Bus 需要创建订阅级别的管理员权限。
当我只是资源组管理员而不是订阅管理员时,当我尝试创建命名空间时遇到了同样的错误,但是一旦我成为订阅管理员,我就没有任何问题。
【讨论】:
我遇到了这个问题,并确定这是因为我的免费试用已经结束。我创建了一个新帐户,开始了新的免费试用,并且成功了。
【讨论】:
一般尝试解析<namespace name>.servicebus.windows.net IP 地址,例如在Windows 上它是nslookup <namespace name>.servicebus.windows.net。如果能拿到IP地址,说明namespace名字已经被占用,否则应该可以创建namespace。
【讨论】:
命名空间应该是唯一的名称。名称空间名称 PushNotificationHub-ns 已被使用。我使用任何名称都没有任何问题。您可以尝试使用其他浏览器或使用旧的 azure 门户,看看是否可以在那里创建命名空间
【讨论】: