【问题标题】:MQ process amqrmppa get defunct status in LinuxMQ 进程 amqrmppa 在 Linux 中获取失效状态
【发布时间】:2012-09-07 01:08:19
【问题描述】:

我的进程 amqrmppa 显示 defunct 状态有问题,请参阅以下详细信息:

mqm       2055  2912  0 Sep01 ?        00:00:31 [amqrmppa] <defunct>
mqm       2524  2912  0 Sep02 ?        00:00:23 [amqrmppa] <defunct>
mqm       2570  2912  0 Sep03 ?        00:00:21 [amqrmppa] <defunct>
mqm       4754  2912  0 Sep03 ?        00:00:19 [amqrmppa] <defunct>
mqm       5628  2912  0 Sep02 ?        00:00:23 [amqrmppa] <defunct>

我检查了错误日志文件,但没有任何线索。你能帮我弄清楚吗?如何处理?

谢谢

WebSphere MQ for Linux(x86-64 平台) 7.0.1.5 Linux 2.6.32.12-0.7-default

【问题讨论】:

    标签: ibm-mq mq


    【解决方案1】:

    这些是通道池过程。这种状态有几个原因,其中最常见的原因是通道被抢先杀死或这些通道的父进程被杀死。其他不太常见的错误包括编码不正确的通道出口或偶尔出现的错误。 (是的,amqrrmpa 不时出现在 APAR 列表中。)如果不查看通道配置,真的很难提供比这更具体的响应。如果出于安全原因无法发布它们,您需要打开 PMR 并让 IBM 查看它们。具体来说,我会查看通道是在 FASTPATH 还是受信任模式下运行,是否定义了出口等。我还会查看版本和修复包级别,然后查看 APAR 列表以获取以后的修复看看有没有解决问题。如果这些都没有指出潜在问题,那么是时候运行MustGather 程序并打开 PMR。

    无论其价值如何,访问 MustGather 页面并按平台和问题类别向下钻取以获得一些真正有用的诊断建议通常是个好主意。

    【讨论】:

      猜你喜欢
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      相关资源
      最近更新 更多