【问题标题】:Azure Storage Account - Prepare for a failover fails with "Last sync time is unavailable"Azure 存储帐户 - 准备故障转移失败并显示“上次同步时间不可用”
【发布时间】:2020-12-17 04:41:38
【问题描述】:

我有一个“RA-GRS”类型的 Azure 存储帐户,如下所示

美国西部是主要的,美国东部是次要的。

在尝试故障转移到美国东部时失败,如下所示

如何解决这个问题?

注意:我已经关注了这篇文章-Prepare for a failover

【问题讨论】:

  • 这是限制吗?

标签: azure azure-storage-emulator


【解决方案1】:

有一个known issue 在帐户创建或转换为 (RA-)GRS 后 4 小时内无法进行帐户故障转移。这些条件中的任何一种都会导致您提到的错误。

我们目前在帐户故障转移方面存在一个持续问题,其中只能在 LastSyncTime 超过帐户创建时间后 4 小时或帐户转换为 (RA-)GRS 时间后启动。例如。如果帐户是在下午 1 点创建的,那么 LST 应该是下午 5 点,以便故障转移工作。我们目前正在制定解决方案,但我还没有预计到达时间。

您还应该check the last sync time 以确保它可用。

$lastSyncTime = $(Get-AzStorageAccount -ResourceGroupName <resource-group> `
    -Name <storage-account> `
    -IncludeGeoReplicationStats).GeoReplicationStats.LastSyncTime

【讨论】:

  • 存储帐户是在至少 15 天前使用 (RA-)GRS 选项和美国西部作为主要帐户创建的
猜你喜欢
  • 1970-01-01
  • 2020-08-31
  • 2021-04-13
  • 1970-01-01
  • 1970-01-01
  • 2020-07-07
  • 1970-01-01
  • 2021-10-03
  • 1970-01-01
相关资源
最近更新 更多