【问题标题】:Why does New-ELBLoadBalancer fail with a WebException?为什么 New-ELBLoadBalancer 会因 WebException 而失败?
【发布时间】:2015-05-25 09:27:01
【问题描述】:

我正在尝试使用下面的脚本使用 powershell 创建一个 ELB,但它失败了 "New-ELBLoadBalancer : A WebException with status NameResolutionFailure was throwed." 我不知道该去哪里开始,有什么提示吗?

$HTTPListener = New-Object -TypeName ‘Amazon.ElasticLoadBalancing.Model.Listener’
$HTTPListener.Protocol = ‘http’
$HTTPListener.InstancePort = 80
$HTTPListener.LoadBalancerPort = 80

New-ELBLoadBalancer -LoadBalancerName 'my-elb' -Listener $HTTPListener -Scheme 'internet-facing' -SecurityGroup 'sg-74d60410' -Subnet 'subnet-efc9b8d5' -AccessKey x -SecretKey x -Region us-west1 

【问题讨论】:

    标签: powershell amazon-web-services amazon-elb aws-powershell


    【解决方案1】:

    我的错,地区名称有错字应该是 us-west-1

    【讨论】:

      【解决方案2】:

      更多关于错误的背景:

      引发了状态为 NameResolutionFailure 的 WebException。

      当您为给定的 AWS cmdlet 指定区域时,您正在调用该区域的特定服务。因此,当您在us-west-1 中调用New-ELBLoadBalancer 时,会在后台对elasticloadbalancing.us-west-1.amazonaws.com 进行API 调用。所以这个 WebException 对 AWS cmdlet 来说很常见,任何使用格式错误的区域创建的 AWS cmdlet 都会抛出这个。

      文档:

      【讨论】:

        猜你喜欢
        • 2013-04-08
        • 1970-01-01
        • 1970-01-01
        • 1970-01-01
        • 2011-04-30
        • 2020-10-14
        • 2012-04-06
        • 2018-05-16
        • 2016-06-25
        相关资源
        最近更新 更多