【问题标题】:Cloudera Manager Failed to authenticate: issue with ssh keyCloudera Manager 无法进行身份验证:ssh 密钥问题
【发布时间】:2016-09-20 14:08:25
【问题描述】:

我正在尝试使用具有 sudo 权限的用户 testuser 使用 2 节点集群测试 Cloudera 安装。 我使用ssh-keygen -t rsa 为每个节点生成了ssh 密钥,并确保将每个节点的id_rsa.pub 复制到另一个节点的.ssh/authorized_keys,即node1 在authorized_keys 中有node2 的pub 密钥,而node2 在authorized_keys 中有node1 的pub 密钥

但是当我将 node1 的 id_rsa 复制到 Cloudera 并运行 Cloudera Manager 安装时,Cloudera 能够验证 node2 但无法验证 node1,同样当我将 node2 的 id_rsa 复制到 Cloudera 时,Cloudera 验证 node1 但无法验证验证节点2 我哪里错了,我应该使用哪个id_rsa

【问题讨论】:

  • 检查密钥的权限

标签: hadoop ssh cloudera


【解决方案1】:

将master的私钥放入所有节点的.ssh/authorized_keys,包括master的。

【讨论】:

    猜你喜欢
    • 2014-12-13
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2021-05-03
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    相关资源
    最近更新 更多