【问题标题】:Server unable to handle request in laravel 5服务器无法在 laravel 5 中处理请求
【发布时间】:2018-05-24 21:42:22
【问题描述】:

我通过它的安装程序安装了 Laravel 5,但我遇到了 500 错误的问题。我改变了 chmod 没有改变(755 用于 root 和 o+w 用于存储)。 使用php -S localhost:8888 ~/bloggy/public 运行服务器 我不知道这是在做什么。

【问题讨论】:

  • 如果出现 500 错误,它应该在其中一个服务器日志中包含更多详细信息,请在您的帖子中包含。

标签: php laravel


【解决方案1】:

我认为你必须在根文件夹(/bloggy)而不是/public 中运行 Laravel,因为在 Laravel 文件结构中,Laravel 使用公共文件夹来读取资产、css、javascript 和其他文件你可以通过 Laravel 助手传递给视图。

【讨论】:

  • 谢谢,但问题不大...routes.php 中有一个错误(可能)。
【解决方案2】:

我遇到了同样的问题。我提出的每一个要求都给了我

服务器无法在 laravel 5 中处理请求。

我收到此错误是因为我配置了auth.php 并在auth.php 中犯了一些错误。我将auth.php 恢复为原始状态,这解决了我的问题。

希望这会有所帮助。干杯

【讨论】:

    猜你喜欢
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2018-12-23
    • 2016-06-09
    • 2017-05-03
    • 1970-01-01
    相关资源
    最近更新 更多