【问题标题】:Mod rewrite causing internal server error, error 500Mod重写导致内部服务器错误,错误500
【发布时间】:2021-01-04 19:56:59
【问题描述】:

所以,我了解了 mod_rewrite 并决定在我的网站上使用它,我的旧网址是这样的

https://xenonmc.tk/?paramOne=register

这是我应该通过 mod_rewirte 获得的输出


https://xenonmc.tk/register

这是我的 htaccess 代码


RewriteEngine On
RewriteRule ^([^/]*)$ /?paramOne=$1 [L]

我认为是问题所在,但我不明白如何解决它,即使在查看了有关此问题的 stackoverflow 上的其他文章后,

我从中了解到的只是 [L] 导致我的 htaccess 从顶部再次循环导致错误。

感谢您的支持。

【问题讨论】:

  • 我建议为您编辑的部分打开一个不同的问题。在得到有效答案后更改您的要求是不公平的。

标签: apache .htaccess mod-rewrite url-rewriting friendly-url


【解决方案1】:

那是因为你在那里创建了一个无限循环,我们需要设置一个条件来避免这种情况(我正在检查查询字符串是否为 NULL,然后仅通过没有无限循环运行规则),尝试:

另外,请确保在检查 URL 之前清除浏览器缓存。

RewriteEngine ON
RewriteCond %{QUERY_STRING} ^$
RewriteRule ^([^/]*)$ /?paramOne=$1 [L]

【讨论】:

  • 还有一个问题,我刚刚用我的实际文件更新了我的问题。 ,我使用了你的方法,第一个 get var 工作了,但是当我添加更多时,它说错误 404,直到我填写所有 url 参数,我应该做什么
  • @Xfaon,老实说,没有看到 htaccess 文件非常困难,你现在解决了一个问题,你很高兴去第二个 :) 所以鼓励在帖子中有 1 个问题,您可以在新问题中分享您的 htaccess,然后我可以看一下,干杯。
猜你喜欢
  • 1970-01-01
  • 1970-01-01
  • 2015-11-23
  • 1970-01-01
  • 1970-01-01
  • 2013-08-11
  • 2012-03-29
  • 2014-04-14
  • 1970-01-01
相关资源
最近更新 更多