【发布时间】:2018-09-07 06:30:54
【问题描述】:
我正在尝试在 MUP 中使用 MONGO_URL: 将我的应用程序连接到 MongoDB。该数据库位于独立的 VPS 上。 VPS 位于防火墙后面,并通过专用网络连接到应用程序 VPS。如果我不使用用户名和密码保护数据库,我可以让它连接,但是如果我创建一个用户以允许 readWrite 命令添加安全性,它将无法连接。我收到此错误。
MongoError: failed to connect to server [private-network-ip:27017]
如果我登录数据库并使用show dbs,则会出现以下内容:
admin 0.000GB
myspecial_db 0.000GB
local 0.000GB
我正在尝试访问myspecial_db。
MONGO_URL: mongodb://username:password@private-network-ip:27017/myspecial_db
我在这里错过了什么?
【问题讨论】:
标签: mongodb meteor meteor-up mup