【问题标题】:Can't connect to a mongodb if it is secure如果安全,则无法连接到 mongodb
【发布时间】:2018-09-07 06:30:54
【问题描述】:

我正在尝试在 MUP 中使用 MONGO_URL: 将我的应用程序连接到 MongoDB。该数据库位于独立的 VPS 上。 VPS 位于防火墙后面,并通过专用网络连接到应用程序 VPS。如果我不使用用户名和密码保护数据库,我可以让它连接,但是如果我创建一个用户以允许 readWrite 命令添加安全性,它将无法连接。我收到此错误。

MongoError: failed to connect to server [private-network-ip:27017]

如果我登录数据库并使用show dbs,则会出现以下内容:

admin         0.000GB
myspecial_db  0.000GB
local         0.000GB

我正在尝试访问myspecial_db

MONGO_URL: mongodb://username:password@private-network-ip:27017/myspecial_db

我在这里错过了什么?

【问题讨论】:

    标签: mongodb meteor meteor-up mup


    【解决方案1】:

    听起来你可以连接到服务器了,这意味着通过防火墙的访问设置正确。

    身份验证很可能发生在 admin 数据库上,在这种情况下,您需要将其添加到 url 的末尾:

    ?authSource=admin

    你也可以试试

    ?authSource=myspecial_db

    如果您担心安全问题,我还想通过添加以下内容来使用 SSL 进行连接:

    &ssl=true

    这将确保您的用户名/密码不会以明文形式发送,并加密传输中的所有数据

    【讨论】:

    • 你是说MONGO_URL: mongodb://username:password@private-network-ip:27017/myspecial_db?authSource=myspecial_db
    • 不,authSource 是用于身份验证的数据库。
    【解决方案2】:

    我遇到的问题与 MONGO_URL 无关,它与服务器设置有关。我使用防火墙阻止了所有传入流量,并且打开的端口不正确。

    【讨论】:

      猜你喜欢
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 2012-02-01
      • 2016-07-31
      • 1970-01-01
      • 2021-12-02
      相关资源
      最近更新 更多