【发布时间】:2021-07-09 20:12:10
【问题描述】:
我在 AWS 上运行两台 t2.medium EC2 服务器。它们都是从同一个 AMI 启动的,并且具有相似的设置、FTP(密码 ofc 除外)和位置。两个服务器的唯一区别是 /var/www/html 文件夹中的内容。
到目前为止,他们一直按预期工作,但昨天开始发生一些奇怪的事情。每当我尝试在其中一台服务器上上传新版本的 (php) 文件时,它都会失败并返回错误“服务器未报告 OK,得到 451”。我尝试了不同的 FTP 用户、不同的 IDE 并重新启动了我的 EC2 服务器,但没有任何运气。这只发生在其中一台服务器上,它开始“出乎意料”地发生
有什么建议可以解决这个问题,或者至少我应该在哪个方向继续调试?
【问题讨论】:
-
451 响应来自您的 FTP 服务器(它转换为:“请求的操作已中止。处理中的本地错误”)。这表明底层 AWS 资源(VPC、网络连接、EC2)没有问题,但问题出在 ec2 实例上运行的操作系统/软件上。我会检查你的 ftp 服务器的日志文件是否有潜在的错误。
标签: amazon-web-services amazon-ec2 ftp centos