【问题标题】:Elasticsearch throwing the exception: NoNodeAvailableException occured : No node availableElasticsearch 抛出异常:NoNodeAvailableException 发生:没有可用节点
【发布时间】:2012-12-28 16:06:27
【问题描述】:

我决定在一个简单的待办事项列表应用程序上尝试第一次使用 elasticsearch。我按照this video 使用该模块并在模块本身中没有进行任何修改,我所做的只是创建应用程序并在控制器中添加类 search.java。

Execution exception
NoNodeAvailableException occured : No node available

In {module:elasticsearch-0.4}/app/controllers/elasticsearch/ElasticSearchController.java (around line 367)

363:
            // FIXME Currently we ignore the orderBy and order fields
364:
            query.from((page - 1) * getPageSize()).size(getPageSize());
365:
            query.hydrate(true);
366:

367:
            return query.fetch();
368:
        }

【问题讨论】:

    标签: playframework elasticsearch


    【解决方案1】:

    我遇到了同样的问题,我所做的是:

    1.检查节点是否打开了正确的端口:

    telnet [ip address] 9300
    Trying [ip address]
    Connected to mynode1 ([ip address]).
    Escape character is '^]'.
    telnet> quit
    Connection closed.    
    

    2.用telnet检查一切正常=):

    $ telnet [ip address] 9400
    Trying [ip address]...
    telnet: Unable to connect to remote host: Connection refused
    

    3.确保您拥有正确版本的elasticsearch!

    elasticsearch plugin 中,我使用的是 elastisearch 0.19.10。当我在我的服务器上安装 elasticsearch 时,我不小心使用了 0.20.1,导致: NoNodeAvailableException 发生:没有可用的节点异常。

    希望这会有所帮助!

    【讨论】:

      【解决方案2】:
      1. 您是否在 application.conf 中配置了 elasticsearch 节点?进一步来说 elasticsearch.client=mynode1:9200,mynode2:9200

      2. 您还可以使用elasticsearch-head plugin 来检查您的elasticsearch 节点是否运行良好。

      【讨论】:

        猜你喜欢
        • 1970-01-01
        • 1970-01-01
        • 1970-01-01
        • 1970-01-01
        • 1970-01-01
        • 1970-01-01
        • 2020-02-05
        • 2013-11-17
        • 2014-07-07
        相关资源
        最近更新 更多