【问题标题】:AWS ec2 WordPress powered by Bitnami instance mysql passwordAWS ec2 WordPress 支持 Bitnami 实例 mysql 密码
【发布时间】:2016-11-10 04:09:34
【问题描述】:

我通过 AWS Marketplace“由 Bitnami 提供支持的 WordPress”图像设置了一个 ec2 实例。设置简单无痛,我能够登录,更改用户密码等。我能够通过 ubuntu 用户 ssh 进入盒子,这很好。

然后是 mysql,我想确保我可以登录数据库以提供备份,以防需要进行调查等。对于我和谷歌的生活,我似乎无法登录. 此外,MySql 的常用“重置 root 密码”方法似乎不适用于此图像,它们会吐出错误。

有人知道这张图片的 MySql 部分的默认密码吗?

我尝试过的一些用户名: root, ubuntu, bitnami, {wordpress 用户名}

我用上述用户名尝试过的密码: "", mysql, bitnami, {wordpress 密码}

在过去 2 天里还有很多其他人。如上所述,通常当您想重置 root 密码时,您可以在安全模式下运行 mysqld 并更改它或运行 mysql_secure_installation 但我收到诸如此类的错误(以我自己和 root 身份尝试):

2016-11-09T19:31:09.279114Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2016-11-09T19:31:09.279195Z 0 [Note] --secure-file-priv is set to NULL. Operations related to importing and exporting data are disabled
2016-11-09T19:31:09.279221Z 0 [Note] /opt/bitnami/mysql/bin/mysqld.bin (mysqld 5.7.16) starting as process 6459 ...
2016-11-09T19:31:09.281916Z 0 [ERROR] Fatal error: Please read "Security" section of the manual to find out how to run mysqld as root!

2016-11-09T19:31:09.282111Z 0 [ERROR] Aborting

2016-11-09T19:31:09.282164Z 0 [Note] Binlog end
2016-11-09T19:31:09.282219Z 0 [Note] /opt/bitnami/mysql/bin/mysqld.bin: Shutdown complete

我正要删除图像并自己安装所有东西,但我想一定有人知道。

【问题讨论】:

  • 嗨@gwnp,这里是Bitnami 开发人员。访问 MySQL 的默认用户名和密码是 root 和用于访问 WordPress 的密码。 docs.bitnami.com/aws/apps/wordpress/… 如果您无法使用这些凭证访问,能否请您告诉我们您使用 AWS Marketplace 启动的 WordPress 版本?
  • 我认为这是最初的 wordpress 密码,因为它不接受我的新密码。几天前,我通过 AWS 的市场 Wordpress Bitnami 图像创建了该实例。 wp-admin 中的版本是“4.6.1 版”
  • 以防万一有人需要...获取初始 wordpress 密码,您可以运行 $ more /opt/bitnami/var/log/pre-start.log

标签: mysql wordpress amazon-web-services amazon-ec2 bitnami


【解决方案1】:

呃,他们的文档中有一个错误,他们说要运行这个:

sudo /opt/bitnami/mysql/bin/mysqld_safe --defaults-file=/opt/bitnami/mysql/my.cnf --pid-file=/opt/bitnami/mysql/data/mysqld.pid --datadir==/opt/bitnami/mysql/data --init -file=/home/bitnami/mysql-init 2> /dev/null &

但是datadir arg有一个额外的等号,命令应该是:

sudo /opt/bitnami/mysql/bin/mysqld_safe --defaults-file=/opt/bitnami/mysql/my.cnf --pid-file=/opt/bitnami/mysql/data/mysqld.pid --datadir=/opt/bitnami/mysql/data --init-file=/home/bitnami/mysql-init 2> /dev/null &

【讨论】:

  • 嗨@gwnp,这里是Bitnami 开发人员。如果您在使用正确的 --datadir 选项后继续遇到问题,能否告诉我们?我们将在我们这边打开一个任务来修复我们文档系统中的文档
  • 嗨@JotaMartos,在我更正此问题后,我能够重置root密码而没有其他问题。谢谢,我今天打算寻找一种方法来实际通知你们这个错误。
猜你喜欢
  • 2015-06-27
  • 1970-01-01
  • 1970-01-01
  • 2019-06-09
  • 2019-08-11
  • 2017-03-15
  • 2018-09-07
  • 2014-10-07
  • 1970-01-01
相关资源
最近更新 更多