【发布时间】:2016-05-07 05:48:57
【问题描述】:
从 Amazon EC2 实例中,我删除了默认的 MySQL 5.1 并按照以下说明安装了 MySQL 5.6:
http://sharadchhetri.com/2013/12/26/install-mysql-server-5-6-in-centos-6-x-and-red-hat-6-x-linux/
虽然安装了,但无法启动mysqld,这里是日志文件:
140112 23:16:53 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
2014-01-12 23:16:54 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2014-01-12 23:16:54 7601 [Note] Plugin 'FEDERATED' is disabled.
2014-01-12 23:16:54 7601 [Note] InnoDB: The InnoDB memory heap is disabled
2014-01-12 23:16:54 7601 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2014-01-12 23:16:54 7601 [Note] InnoDB: Compressed tables use zlib 1.2.3
2014-01-12 23:16:54 7601 [Note] InnoDB: Using Linux native AIO
2014-01-12 23:16:54 7601 [Note] InnoDB: Not using CPU crc32 instructions
2014-01-12 23:16:54 7601 [Note] InnoDB: Initializing buffer pool, size = 128.0M
2014-01-12 23:16:54 7601 [Note] InnoDB: Completed initialization of buffer pool
2014-01-12 23:16:54 7601 [ERROR] InnoDB: auto-extending data file ./ibdata1 is of a different size 640 pages (rounded down to MB) than specified in the .cnf file: initial 768 pages, max 0 (relevant if non-zero) pages!
2014-01-12 23:16:54 7601 [ERROR] InnoDB: Could not open or create the system tablespace. If you tried to add new data files to the system tablespace, and it failed here, you should now edit innodb_data_file_path in my.cnf back to what it was, and remove the new ibdata files InnoDB created in this failed attempt. InnoDB only wrote those files full of zeros, but did not yet use them in any way. But be careful: do not remove old data files which contain your precious data!
2014-01-12 23:16:54 7601 [ERROR] Plugin 'InnoDB' init function returned error.
2014-01-12 23:16:54 7601 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
2014-01-12 23:16:54 7601 [ERROR] Unknown/unsupported storage engine: InnoDB
2014-01-12 23:16:54 7601 [ERROR] Aborting
2014-01-12 23:16:54 7601 [Note] Binlog end
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'partition'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'PERFORMANCE_SCHEMA'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'BLACKHOLE'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'ARCHIVE'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'INNODB_SYS_DATAFILES'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'INNODB_SYS_TABLESPACES'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'INNODB_SYS_FOREIGN_COLS'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'INNODB_SYS_FOREIGN'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'INNODB_SYS_FIELDS'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'INNODB_SYS_COLUMNS'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'INNODB_SYS_INDEXES'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'INNODB_SYS_TABLESTATS'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'INNODB_SYS_TABLES'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'INNODB_FT_INDEX_TABLE'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'INNODB_FT_INDEX_CACHE'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'INNODB_FT_CONFIG'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'INNODB_FT_BEING_DELETED'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'INNODB_FT_DELETED'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'INNODB_FT_DEFAULT_STOPWORD'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'INNODB_METRICS'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'INNODB_BUFFER_POOL_STATS'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'INNODB_BUFFER_PAGE_LRU'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'INNODB_BUFFER_PAGE'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'INNODB_CMP_PER_INDEX_RESET'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'INNODB_CMP_PER_INDEX'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'INNODB_CMPMEM_RESET'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'INNODB_CMPMEM'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'INNODB_CMP_RESET'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'INNODB_CMP'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'INNODB_LOCK_WAITS'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'INNODB_LOCKS'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'INNODB_TRX'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'MyISAM'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'MRG_MYISAM'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'CSV'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'MEMORY'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'sha256_password'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'mysql_old_password'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'mysql_native_password'
2014-01-12 23:16:54 7601 [Note] Shutting down plugin 'binlog'
2014-01-12 23:16:54 7601 [Note] /usr/sbin/mysqld: Shutdown complete
解决此问题的步骤是什么?谢谢。
【问题讨论】:
标签: amazon-ec2 mysql