【问题标题】:Migrating the wso2 APIs and Applications to a Different Environment将 wso2 API 和应用程序迁移到不同的环境
【发布时间】:2019-10-30 23:20:13
【问题描述】:

我正在设置 API Manager 导入和导出工具,我们需要将“api-import-export-2.6.0-v10.war”文件部署到“/repository/deployment/server/webapps 文件夹”,其中它抛出一个错误。 Web 应用程序 [/api-import-export-2.6.0-v10] 中的 StandardContext Servlet [JAXServlet] 引发 load() 异常

我正在使用 API Manager 2.6.0 并部署了相同版本的 .war 文件的“api-import-export-2.6.0-v10.war”。尝试了另一个错误相同的系统。

错误 - Web 应用程序 [/api-import-export-2.6.0-v10] 中的 StandardContext Servlet [JAXServlet] 引发 load() 异常 java.lang.ClassNotFoundException: org.apache.cxf.transport.servlet.CXFServlet

【问题讨论】:

    标签: wso2 wso2-am wso2dss


    【解决方案1】:

    尝试以前版本的 jar 并告诉我它是否有效。

    【讨论】:

      【解决方案2】:

      要使用最新的war文件,您需要WUM更新WSO2 APIM 2.6.0。您收到此错误是因为您尚未 WUM 更新 WSO2 APIM 2.6.0。在文档中,在第 1 步下,您可以获取以前的版本[1],或者您可以按照 [2] WUM 更新 WSO2 API Manager。

      [1] - https://docs.wso2.com/display/AM260/Migrating+the+APIs+and+Applications+to+a+Different+Environment [2] - https://docs.wso2.com/display/AM260/Updating+WSO2+API+Manager

      【讨论】:

        【解决方案3】:

        我已将问题解决为 apimcli、导入/导出 war 文件和 WSO2 API-M 服务器之间的版本兼容性。

        问题是由于 WSO2 提到的兼容版本 (api-import-export-2.6.0-v10) 无法与我们的 APIM 服务器正常工作并尝试降低版本并正常工作现在。

        WSO2 API-M 版本:2.6.0 导入/导出工具版本:APIMCLI v2.0.1 [为 apimcli 下载的 Zip 文件可以使用,在我的情况下不需要额外的配置] 导入/导出 WAR 文件版本:api-import-export-2.5.0-v1 [war 文件已热部署到以下路径 wso2am/2.6.0/repository/deployment/server/webapps/]

        执行以下命令:

        从 DEV 环境中导出了已创建的 API: $ ./apimcli export-api -n ProfileManagementNJ -v v1.0.0 -r admin -e dev -k

        成功导出 API! 在 /home/stwso2/.wso2apimcli/exported/apis/dev/ProfileManagementNJ_v1.0.0.zip 中找到导出的 API

        将上述导出的 API 导入 ST 环境: $ ./apimcli import-api -k -f /home/stwso2/.wso2apimcli/exported/apis/dev/ProfileManagementNJ_v1.0.0.zip -e st --preserve-provider false

        成功导入 API

        可以在下面找到实际的错误消息详细信息,并从控制台日志中捕获: $ ./apimcli export-api -n ProfileManagementNJ -v 1.0.0 -r admin -e st -k --verbose

        在 2019 年 10 月 30 日星期三 13:41:52 UTC 执行 ImportExportCLI (apimcli)

        [INFO]:不安全:真

        [INFO]: 调用导出 api

        [INFO]:ExportAPI:网址:https://172.26.41.4:9443/api-import-export-2.6.0-v10/export-api?name=ProfileManagementNJ&version=1.0.0&provider=admin&preserveStatus=true

        apimcli:导出时出错原因:获取https://172.26.41.4:9443/carbon/admin/login.jsp:自动重定向已禁用

        退出状态1

        有关 apimcli 设置的更多详细信息:https://docs.wso2.com/display/AM260/Migrating+the+APIs+to+a+Different+Environment#Example-exportAPI

        【讨论】:

          猜你喜欢
          • 1970-01-01
          • 1970-01-01
          • 1970-01-01
          • 1970-01-01
          • 1970-01-01
          • 2019-02-23
          • 1970-01-01
          • 1970-01-01
          • 2018-08-02
          相关资源
          最近更新 更多