【问题标题】:Error in starting Wildfly 8.0 server with JDK 1.8使用 JDK 1.8 启动 Wildfly 8.0 服务器时出错
【发布时间】:2015-04-08 11:33:51
【问题描述】:

我在启动服务器时收到此错误。我尝试了一切,但仍然不确定原因是什么。请帮忙

谢谢

java.lang.IllegalArgumentException: Failed to instantiate class "org.jboss.logmanager.handlers.PeriodicRotatingFileHandler" for handler "FILE"
    at org.jboss.logmanager.config.AbstractPropertyConfiguration$ConstructAction.validate(AbstractPropertyConfiguration.java:119)
    at org.jboss.logmanager.config.LogContextConfigurationImpl.doPrepare(LogContextConfigurationImpl.java:338)
    at org.jboss.logmanager.config.LogContextConfigurationImpl.prepare(LogContextConfigurationImpl.java:291)
    at org.jboss.logmanager.config.LogContextConfigurationImpl.commit(LogContextConfigurationImpl.java:300)
    at org.jboss.logmanager.PropertyConfigurator.configure(PropertyConfigurator.java:542)
    at org.jboss.logmanager.PropertyConfigurator.configure(PropertyConfigurator.java:97)
    at org.jboss.logmanager.LogManager.readConfiguration(LogManager.java:300)
    at org.jboss.logmanager.LogManager.readConfiguration(LogManager.java:262)
    at java.util.logging.LogManager$3.run(LogManager.java:399)
    at java.util.logging.LogManager$3.run(LogManager.java:396)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.util.logging.LogManager.readPrimordialConfiguration(LogManager.java:396)
    at java.util.logging.LogManager.access$800(LogManager.java:145)
    at java.util.logging.LogManager$2.run(LogManager.java:345)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.util.logging.LogManager.ensureLogManagerInitialized(LogManager.java:338)
    at java.util.logging.LogManager.getLogManager(LogManager.java:378)
    at org.jboss.modules.Main.main(Main.java:438)
Caused by: java.lang.reflect.InvocationTargetException
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
    at java.lang.reflect.Constructor.newInstance(Constructor.java:408)
    at org.jboss.logmanager.config.AbstractPropertyConfiguration$ConstructAction.validate(AbstractPropertyConfiguration.java:117)
    ... 17 more
Caused by: java.io.FileNotFoundException: C:\Program Files\wildfly-8.0.0.Final\wildfly-8.0.0.Final\standalone\log\boot.log (The system cannot find the path specified)
    at java.io.FileOutputStream.open(Native Method)
    at java.io.FileOutputStream.<init>(FileOutputStream.java:206)
    at org.jboss.logmanager.handlers.FileHandler.setFile(FileHandler.java:154)
    at org.jboss.logmanager.handlers.PeriodicRotatingFileHandler.setFile(PeriodicRotatingFileHandler.java:105)
    at org.jboss.logmanager.handlers.FileHandler.setFileName(FileHandler.java:192)
    at org.jboss.logmanager.handlers.FileHandler.<init>(FileHandler.java:122)
    at org.jboss.logmanager.handlers.PeriodicRotatingFileHandler.<init>(PeriodicRotatingFileHandler.java:73)
    ... 22 more
Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0

【问题讨论】:

    标签: jboss wildfly


    【解决方案1】:

    主要错误是这个:

    原因:java.io.FileNotFoundException: C:\Program Files\wildfly-8.0.0.Final\wildfly-8.0.0.Final\standalone\log\boot.log

    检查文件是否存在和/或没有可能阻止 Java 创建该文件的权限限制。

    问题的最后一行:

    另外 22 个 Java HotSpot(TM) 64 位服务器虚拟机警告:忽略选项 MaxPermSize=256m; 8.0 中移除了支持

    似乎表明 WildFly 8.0 未通过 Java 8 认证。也就是说,它不是为在 Java 8 上运行而设计的,因此,虽然它很有可能在 Java 8 下启动,但可能会出现一些意想不到的行为。

    如果可能,我建议您将 WildFly 升级到最新的稳定版本(截至目前为 8.2),或者如果不可能,请将您的 Java 版本降级到 7。

    【讨论】:

    • 感谢回复 我试图创建一个补丁文件(boot.log),但错误再次出现“访问被拒绝”如何查明访问限制问题?
    • 确实是 Windows 问题,但您可以试试这个...(1) 右键单击​​顶级 WildFly 文件夹 (2) 单击安全选项卡 (3) 选择您的用户(运行 WildFly )(4)点击高级(5)在新窗口中选择您的用户(6)点击“更改权限”(7)选择您的用户+点击“编辑”(8)确保所有读/写权限都被允许,点击确定(9)、勾选“用可继承权限替换所有子对象权限......”框 (10) 点击应用 (11) 在所有打开的窗口上点击确定,然后重试。
    【解决方案2】:

    您使用的是 Windows 10 吗?

    Similar issue with windows10

    如果是这样,请尝试通过命令提示符 (admin) 而不是普通的 cmd 启动服务器。

    要访问它,只需右键单击“开始”,您就会看到它。

    谢谢, 本

    【讨论】:

      猜你喜欢
      • 2020-03-02
      • 2021-04-14
      • 2016-05-16
      • 1970-01-01
      • 1970-01-01
      • 2018-01-05
      • 2013-05-05
      • 2016-09-24
      • 2015-02-18
      相关资源
      最近更新 更多