【问题标题】:Kubernetes kube-dns restarts on master nodeKubernetes kube-dns 在主节点上重启
【发布时间】:2019-02-26 05:24:51
【问题描述】:

我在 Ubuntu 16.04 服务器上有 Kubernetes 集群,使用 Kubespray 进行部署。

Kube-dns pod 在主节点上不断重启。它已重新启动 3454 次。

谁能告诉我如何解决这个问题?

kube-dns 的启动日志: # 1, # 2

k8s-cluster.yml #1#2

【问题讨论】:

  • 请详细说明您的问题和要求。有人如何通过仅提供链接或图像来帮助您。以文本格式输入您的代码。
  • @Suraj Kumar 请检查。
  • 你能显示你的yaml文件吗?
  • 请检查 k8s-cluster.yml

标签: kubernetes ubuntu-16.04 kube-dns


【解决方案1】:

SkyDNS 默认将名称服务器转发到/etc/resolv.conf 中列出的那些。由于SkyDNS 作为集群插件在kube-dns pod 内运行,它从其主机继承/etc/resolv.conf 的配置,如kube-dns documentations 中所述。

根据您的错误,您的主机的 /etc/resolv.conf 似乎配置为使用 10.233.100.1 作为其名称服务器,并成为您的 SkyDNS 配置中的转发服务器。看起来 10.233.100.1 无法从您的 Kubernetes 集群路由,这就是您收到错误的原因:

skydns: failure to forward request "read udp 10.233.100.1:40155->ourdnsserverIP:53:  i/o timeout"

解决方案是在SkyDNS 配置中更改标志--nameservers。我说更改是因为当前您将其设置为“”,您可能会将其更改为nameservers=8.8.8.8:53,8.8.4.4:53

【讨论】:

    猜你喜欢
    • 1970-01-01
    • 2017-07-27
    • 2018-08-07
    • 1970-01-01
    • 2017-09-17
    • 2017-08-15
    • 2018-12-24
    • 2020-08-24
    • 2016-02-13
    相关资源
    最近更新 更多