【发布时间】:2017-09-25 20:32:06
【问题描述】:
当我按照使用artifactory plugin with docker 的说明进行操作时,为什么会出现/v1/_ping: Bad Gateway 错误?
- jenkins 2.60.3 和 Artifactory 插件 2.12.2
-
Enable Build-Info proxy for Docker images9999 端口 - jenkins
/var/lib/jenkins/secrets/jfrog/certs/jfrog.proxy.crt添加到 jenkins master 和 slave 上的 $JAVA_HOME/jre/lib/security/cacerts - jfrog nginx 自签名证书添加到 jenkins master 和 slave 上的 $JAVA_HOME/jre/lib/security/cacerts
- 访问 jenkins:9999 在主机之间打开
-
/etc/systemd/system/docker.service.d/http-proxy.conf包含以下内容,与测试没有区别[服务] 环境="HTTP_PROXY=http://jenkins:9999/"
[服务] 环境="HTTPS_PROXY=https://jenkins:9999/"
本地 docker 测试 (
docker login 127.0.0.1:9999) 结果
Error response from daemon: Login: Bad Request to URI: /v1/users/ (Code: 400; Headers: map[Content-Length:[30] Content-Type:[text/html; chars...
- Jenkins 测试结果在
com.github.dockerjava.api.exception.BadRequestException: Bad Request to URI: /images/artifactory:<port>/hello-world:latest/json
Jenkins 日志中的错误
SEVERE: (DISCONNECTED) [id: ..., L:0.0.0.0/0.0.0.0:... ! R:artifactory/...:5000]:
Caught an exception on ProxyToServerConnection
io.netty.handler.codec.DecoderException:
javax.net.ssl.SSLHandshakeException: General SSLEngine problem
...
Caused by: sun.security.validator.ValidatorException: PKIX path building
failed: sun.security.provider.certpath.SunCertPathBuilderException:
unable to find valid certification path to requested target
我的虚拟存储库,当我不使用 jenkins 代理时它的远程和本地工作,但根据插件文档,我需要 jenkins 代理来获取我需要的构建信息以进行 CI/CD 推广。
【问题讨论】:
标签: docker jenkins-plugins artifactory