【问题标题】:How do I delete client from a perforce server that won't start如何从无法启动的 perforce 服务器中删除客户端
【发布时间】:2014-12-21 14:32:49
【问题描述】:

我终于可以将我的 perforce 服务器升级到 2014 版了。

我有一个单用户管理员许可证,但没有支付年度升级费用,因为我认为新的免费许可证会适合我 - 20 个客户。我刚刚删除了旧的许可证文件。

我没有意识到我有 29 个客户。

我收到此错误消息

C:\Program Files\Perforce\NewServer>p4d
Perforce server error:
    Unlicensed server cannot start while over user/client quota.
    Try deleting old clients with 'client -d'.
    License count: 29 clients used of 20 licensed.

有没有一种方法可以选择 29 个客户端进行删除?显然 p4 客户端命令不会连接,因为服务器没有运行。我可以针对p4d 或类似的东西运行该命令吗?

我将在周一联系 perforce 支持,但我想知道我自己能做些什么。

【问题讨论】:

    标签: perforce p4v


    【解决方案1】:

    我们刚刚受到打击。最后我们发了一个

    "p4d -n -p 1666" 
    

    这使我们进入维护模式。然后我们可以删除客户端规格。删除一些后,我们可以重新启动服务器。

    【讨论】:

    • 也有这个问题,这是迄今为止最简单的解决方案。作为一种魅力。
    【解决方案2】:

    我不知道我想做的事情是否有解决方案,但这就是我解决它的方法。

    我在升级之前创建了我的 perforce 目录的完整备份。

    1. 解压备份
    2. 在备份目录中打开“cmd”
    3. 从命令行运行p4d,启动perforce服务器
    4. 与普通 p4v 客户端连接
    5. 删除所有其他客户端
    6. 关闭 p4d 窗口以杀死 perforce 实例
    7. 创建检查点
    8. 从真实文件夹中删除 db.* 文件
    9. 将新创建的检查点恢复到真实文件夹。

    现在一切正常。

    【讨论】:

      猜你喜欢
      • 2020-02-07
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 2012-10-25
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      相关资源
      最近更新 更多